summaryrefslogtreecommitdiff
path: root/app-mobilephone/pysms/pysms-0.9.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/pysms/pysms-0.9.4-r1.ebuild')
-rw-r--r--app-mobilephone/pysms/pysms-0.9.4-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-mobilephone/pysms/pysms-0.9.4-r1.ebuild b/app-mobilephone/pysms/pysms-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..492f6b098e02
--- /dev/null
+++ b/app-mobilephone/pysms/pysms-0.9.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool for sending text messages for various Swiss providers"
+HOMEPAGE="https://sourceforge.net/projects/pysms/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygtk[${PYTHON_USEDEP}]"
+
+python_prepare() {
+ sed -e "s:0.9.1:0.9.4:" \
+ -e "s/Application;Network/Network/" \
+ -i data/pysms.desktop || die
+ rm -f MANIFEST.in
+
+ distutils-r1_python_prepare
+}