summaryrefslogtreecommitdiff
path: root/app-mobilephone/cobex/cobex-0.2.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/cobex/cobex-0.2.13.ebuild')
-rw-r--r--app-mobilephone/cobex/cobex-0.2.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-mobilephone/cobex/cobex-0.2.13.ebuild b/app-mobilephone/cobex/cobex-0.2.13.ebuild
new file mode 100644
index 000000000000..060d72031b58
--- /dev/null
+++ b/app-mobilephone/cobex/cobex-0.2.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils
+
+DESCRIPTION="small implementation of Obex for phones using the DCU-11 USB-to-serial adapter"
+HOMEPAGE="http://cobex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cobex/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-libs/libezV24
+ dev-libs/expat"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ local f
+ for f in get ls mkdir put rm ; do mv ${f}.c cobex_${f}.c || die ; done
+}
+
+src_install() {
+ dobin cobex_{ls,mkdir,put,rm} || die
+ dodoc Changelog README Things_to_know_T310.txt
+}