summaryrefslogtreecommitdiff
path: root/app-mobilephone/anyremote/anyremote-6.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/anyremote/anyremote-6.5.ebuild')
-rw-r--r--app-mobilephone/anyremote/anyremote-6.5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-mobilephone/anyremote/anyremote-6.5.ebuild b/app-mobilephone/anyremote/anyremote-6.5.ebuild
new file mode 100644
index 000000000000..8f44f2a4b9c0
--- /dev/null
+++ b/app-mobilephone/anyremote/anyremote-6.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Bluetooth, infrared or cable remote control service"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="bluetooth dbus zeroconf"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/libX11
+ x11-libs/libXtst
+ bluetooth? ( net-wireless/bluez )
+ dbus? (
+ dev-libs/dbus-glib
+ sys-apps/dbus
+ )
+ zeroconf? ( net-dns/avahi )
+"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}/" \
+ $(use_enable bluetooth) \
+ $(use_enable dbus) \
+ $(use_enable zeroconf avahi)
+}
+
+src_install() {
+ default
+ mv "${ED}"/usr/share/doc/${PF}/{doc-html,html} || die
+}