summaryrefslogtreecommitdiff
path: root/app-misc
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/Manifest.gzbin49094 -> 49098 bytes
-rw-r--r--app-misc/countrycodes/Manifest3
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.6.ebuild29
-rw-r--r--app-misc/countrycodes/files/1.0.6-Makefile.patch35
-rw-r--r--app-misc/tmux/Manifest2
-rw-r--r--app-misc/tmux/tmux-3.3a.ebuild2
6 files changed, 69 insertions, 2 deletions
diff --git a/app-misc/Manifest.gz b/app-misc/Manifest.gz
index b6fbbb2e7e71..95e10c2c0655 100644
--- a/app-misc/Manifest.gz
+++ b/app-misc/Manifest.gz
Binary files differ
diff --git a/app-misc/countrycodes/Manifest b/app-misc/countrycodes/Manifest
index 47350d04938b..fade5980f659 100644
--- a/app-misc/countrycodes/Manifest
+++ b/app-misc/countrycodes/Manifest
@@ -1,4 +1,7 @@
AUX 1.0.5-Makefile.patch 1010 BLAKE2B a45e729398432a402296a57a6b82cf994bd91608c3af5ed1aaaaaca399930f7d14220eb932bff6fe89d7989c7a6e3f29bd4652cdfd2e82608217fdabcbc46d4f SHA512 73b43a54e52490ee662cb7af7505d4d0bccbd16851b19010be36e0b309bd0d81636ef855cdb1c49f83c9d7dbac036191eaf8b38396759b1e14588b28a9dd1f17
+AUX 1.0.6-Makefile.patch 728 BLAKE2B e94780600af8855903af12f0ac2b3645d8080bb38753cdc107a04d4ead1c8b2ef26c4c68d230ba4eef3431af8a97852e1871068c90513fb2eb70ec9a34408646 SHA512 0bc5828d6c4b587e508fa01355bef6b3a95918118adfedd4c1502845706534336e20ecacda637c4f42193ccce2b4d20b51d93062002cef4d897e4d65d95defc9
DIST countrycodes-1.0.5.tar.gz 18621 BLAKE2B 1f2e1fb0f96d1388687929895c310e1e93c320f4d3f3f4cfe19c50d2ab850bafcefb5e13cfdaed546237ae5873eb95ae574ac47c0048bc2fa37c96158b5082fe SHA512 d62beaaccdbc8f7e14f3edf0044aeeef6375a3deffc0e4246a49fb8209ed7256208c878f811950c5c3bfda729988a46c173aecec72ee66e8843932d97064f035
+DIST countrycodes-1.0.6.tar.gz 18834 BLAKE2B b5e0806618da0dd740a890b9c4d369cf2c44182515ec91aaa08a5e19da447635fb8536611a278ffcc419b506efa07df7e71bf5d520895a059c4aaa6e0cbc9b48 SHA512 be069593f60f785ef4d2e107340b941902a9c45d81ed04f8518a78f2be610ffdd1675da3da1d07271fc7ab736aabdd9f92f060d132e7b7b41310f1b653c53244
EBUILD countrycodes-1.0.5-r4.ebuild 710 BLAKE2B 049005d915058af95f12a8f2c5c3693206f3386428a1afb3aef62ef92360c073c50996fe312879c3456996387b94f9f18cb4975811c82627468f634821cc6566 SHA512 eb10abc32ee84401560148c65e4e230b4aa8b4d70f5306cec5ddc5d40f5e31cb79e1bafd89059a4550f8b273f8cf36412757b9dd77329e9ffe55bea0ca5b9611
+EBUILD countrycodes-1.0.6.ebuild 652 BLAKE2B f49e767a29d538f33aa88af26cae0d644e662028b27106ebc5928ea1be14276d2f27d417880cc87c1d892a65155b582407bedcb891e5755d07d0704ec7eabfee SHA512 b6c65e764a3aead17f93dbf34b4a710b161a6b5f024837f22727da6307a85cadbab3ffb2c2b0f556efa60ccdc4775561e90b731485135a1b1714f7e54855bfc0
MISC metadata.xml 266 BLAKE2B 74ac06b4ea12603c8713e69cbff9ce6874266fc48ee5c846f0ac3d50bf577c3edb1e4b6690ec44fc4dd51e55e96dd5c2478831c9f754b04661fe7700d8baf66f SHA512 b996554131284e3556af42d2c5032c5b1635de67d48983096991935e7ee04c32aadc93e48cae5160861e86d64eb6fd4abafc40d9dd8b85ddc032b042a77677cb
diff --git a/app-misc/countrycodes/countrycodes-1.0.6.ebuild b/app-misc/countrycodes/countrycodes-1.0.6.ebuild
new file mode 100644
index 000000000000..01499421f229
--- /dev/null
+++ b/app-misc/countrycodes/countrycodes-1.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An ISO 3166 country code finder"
+HOMEPAGE="https://sourceforge.net/projects/countrycodes/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+PATCHES=( "${FILESDIR}"/${PV}-Makefile.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ prefix="${ED}"/usr \
+ mandir="${ED}"/usr/share/man install
+ dosym iso3166 /usr/bin/countrycodes
+ dosym iso3166.1 /usr/share/man/man1/countrycodes
+ dodoc README
+}
diff --git a/app-misc/countrycodes/files/1.0.6-Makefile.patch b/app-misc/countrycodes/files/1.0.6-Makefile.patch
new file mode 100644
index 000000000000..051c02946230
--- /dev/null
+++ b/app-misc/countrycodes/files/1.0.6-Makefile.patch
@@ -0,0 +1,35 @@
+diff --git a/Makefile b/Makefile
+index b6e1323..b11a453 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,10 +23,9 @@ BINMODE=755
+ LOGDIRMODE=700
+
+ # Compiler to use
+-CC=gcc
+
+ # Compiler warnings
+-WARNINGS= -pedantic -Wall
++CFLAGS += -pedantic -Wall
+
+ # Compiler flags
+ CCOPTS = -O2 -fomit-frame-pointer
+@@ -58,7 +57,7 @@ PROGRAM = iso3166
+ all: $(PROGRAM)
+
+ $(PROGRAM): $(ISO3166OBJ)
+- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(ISO3166OBJ) -o $@
+
+ clean:
+ $(RM) $(ISO3166OBJ) core defines.h $(PROGRAM)
+@@ -79,9 +78,6 @@ uninstall:
+ $(RM) ${bindir}/$(PROGRAM)
+ $(RM) ${mandir}/iso3166.1
+
+-.c.o:
+- $(CC) $(CCOPTS) $(WARNINGS) -c $<
+-
+ $(ISO3166OBJ): common.h defines.h protos.h tables.h
+
+ defines.h:
diff --git a/app-misc/tmux/Manifest b/app-misc/tmux/Manifest
index 7019fd64a346..d04d005be476 100644
--- a/app-misc/tmux/Manifest
+++ b/app-misc/tmux/Manifest
@@ -6,6 +6,6 @@ DIST tmux-3.3a.tar.gz 677448 BLAKE2B e835ce0f136175521035a684419f221864edb0a9506
DIST tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b 458 BLAKE2B 04143e6d1cfbbd467f1656f949363cb7a4a3e16e9b3cf56b8b0423babe56276abee2622964cb490005fc76d1cbe12201fb1a6446a6f860c2cc1ff3c9bd5fc496 SHA512 fe0aca7d03067af87e0788a2fa902c7ef5500ba72295cb63c5a1814534a008c224256d7f890ac1af6d17f3734b45148765e1632f075e284c453185df2927b979
EBUILD tmux-3.1c.ebuild 1638 BLAKE2B 0ab8033ed5e3093c794c163f0434e02b15fb8a03e0eec333048bc1a1ea845065cb93de1edbc40f05b3d2c39e842ca5e0037d992846021a0d5e8f82f241dbb48c SHA512 c0bb3466cf8087fdd1bc2bafa298f21fdc44792a1d2c60ec0075fe51a86eaa15913b685d5be26aca949c993023a66d2d1fca9d06c25ee3a9fbab8e7612da464a
EBUILD tmux-3.2a.ebuild 1713 BLAKE2B eaf841e39eddde547d854a7cf96f7637417ec4084a225cff2769598b75c405a101e4005696dc0278d6c84558096b3d3a00ec9e8cb917a9ad862f4a978115f1f1 SHA512 ea9760475aaba6362b185736af49810d421dc18eeba7a1ef9b0afed706a7d78ac6465165e5e0e11586bdd7dc739d03faf8059e1991e065164648cb35f26b06ac
-EBUILD tmux-3.3a.ebuild 1883 BLAKE2B c73547b81abaf46d8a1fce1158cf26c559331b24eeddd48a51c838b19ed12b56adaa54eccf9f122fb3123d2ac75f97d45153f5e99e0714965d118fc9e027101e SHA512 9a154622876c238b69cc264c24c61c9cb59ff92f20edba5f17ddec68329caba57349364a97ee24229ec5c7216ea8cd4b8428b518377106971947ef37738ca266
+EBUILD tmux-3.3a.ebuild 1882 BLAKE2B aa060f467e50544866b4ebe2eb9dfd36281ffd65fa21aacc949f1a26f8f1cca26d5b606602b0200d8768b79b9d962a12077617d41897c920b0035f64487bdb34 SHA512 eff11cf54bf1270d4e8e6c36010061a513ad1c788b6bc64afe0c1b3ec6671d2ba61d664654343d0b744b59e6cc148766216ce0e4857614c14b90e369e11ab8ff
EBUILD tmux-9999.ebuild 1890 BLAKE2B 121d47cc10af25dd799086368f95609885412e8f8934d7db5fb4f3b98048aacce85f8bbdd0980e3e7c1816c2e643393760e190645153862fe1dc1835671980c2 SHA512 2bb0f8b9e52967e7a81e8623d11b023cec05d49e93c1f508ad960b804175480e836708b44292acb7cdbabbc780c2665f97dbed0bb16562a828002149e956bdb9
MISC metadata.xml 817 BLAKE2B 82a6ef0299449e66a441f24d6ababd640926b51a2196573d1d21076e83709db1c4e3ca9a466d8220ac4bc5fb4ae8aee02b49c8573011524e2d9509802553c092 SHA512 5cdbfe700d3c1f37fb1d958ada1078ab22d1236248872f1aad6e311ec0aad1fb32b8988acf2e1ade98ba1a6644ffc39b9a29d553271fa12d73afc27b78c8b141
diff --git a/app-misc/tmux/tmux-3.3a.ebuild b/app-misc/tmux/tmux-3.3a.ebuild
index 3fe40b830188..4f7f1e37b517 100644
--- a/app-misc/tmux/tmux-3.3a.ebuild
+++ b/app-misc/tmux/tmux-3.3a.ebuild
@@ -14,7 +14,7 @@ if [[ ${PV} == 9999 ]] ; then
else
SRC_URI="https://github.com/tmux/tmux/releases/download/${PV}/${P/_/-}.tar.gz"
if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
fi
S="${WORKDIR}/${P/_/-}"
fi