summaryrefslogtreecommitdiff
path: root/app-misc/towitoko/towitoko-2.0.7-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/towitoko/towitoko-2.0.7-r2.ebuild')
-rw-r--r--app-misc/towitoko/towitoko-2.0.7-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/towitoko/towitoko-2.0.7-r2.ebuild b/app-misc/towitoko/towitoko-2.0.7-r2.ebuild
new file mode 100644
index 000000000000..fb31a59e4793
--- /dev/null
+++ b/app-misc/towitoko/towitoko-2.0.7-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+IUSE="moneyplex"
+
+DESCRIPTION="Provides a driver for using Towitoko smartcard readers under UNIX environment"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="https://www.gentoo.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc x86"
+
+src_compile() {
+ local myconf
+
+ myconf=""
+ use moneyplex && myconf="${myconf} --disable-atr-check"
+
+ econf \
+ $(use_enable moneyplex win32-com) \
+ ${myconf} || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ if ! use moneyplex
+ then
+ elog "If you want to use the moneyplex home banking software from"
+ elog "http://www.matrica.de"
+ elog "then please re-emerge this package with 'moneyplex' in USE"
+ fi
+}