summaryrefslogtreecommitdiff
path: root/app-misc/tkpasman
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tkpasman')
-rw-r--r--app-misc/tkpasman/Manifest4
-rw-r--r--app-misc/tkpasman/files/tkpasman-2.2a-gentoo.patch22
-rw-r--r--app-misc/tkpasman/metadata.xml5
-rw-r--r--app-misc/tkpasman/tkpasman-2.2b.ebuild39
4 files changed, 70 insertions, 0 deletions
diff --git a/app-misc/tkpasman/Manifest b/app-misc/tkpasman/Manifest
new file mode 100644
index 000000000000..0f1cceb0d414
--- /dev/null
+++ b/app-misc/tkpasman/Manifest
@@ -0,0 +1,4 @@
+AUX tkpasman-2.2a-gentoo.patch 771 BLAKE2B 3ac72ed705357db279e5584412146c8a1e8079dca474bb679df89e46ea5e144978b4e6d9d7bc4a987cc9283e1fa22e57296304e018e4ebcac225915500f4d14b SHA512 6d0fca1b86d5e3a980245510ff98979ef4f9cd85cfdee6fee37e19b83824471fbf8154768ad8921d1ea9bced218c5b2a117022907c81f1775d332530680ea260
+DIST TkPasMan-2.2b.tar.gz 31365 BLAKE2B 46588abfdc321b0b57da94b585c3bdc1ec724c8f30f6275aa428c0b5ee21b8ba486a0ac927f8062ff0ed38418933351346d4f44062b601355ee677f0ad1b3a6e SHA512 ca74ed6a5989c21b266ff4bed00963d46eb05e1a7a0822dceeae5c87bcbb7bf36a775eedf86244fa1121008a6df59fa38003e07e8cb6e4ddf98c895b61f24f12
+EBUILD tkpasman-2.2b.ebuild 784 BLAKE2B ab79f669c7e99180d4f0a505033d2ccb1c6b4b9d77f0d917b3a05fa60252e717ffeb3730401d28eb28119ef55a46a25beaaf70e2307ee775f5d92d4eee9e11a9 SHA512 6eacde9f32fd49c317705d52b21a24f936b7ff590c3648d5a456efea94a37fa70fbdb208e8f26b6efc0b507f90585c68f14a0263ec11617e36a1438b58e7c6ae
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-misc/tkpasman/files/tkpasman-2.2a-gentoo.patch b/app-misc/tkpasman/files/tkpasman-2.2a-gentoo.patch
new file mode 100644
index 000000000000..d52d5129b7c7
--- /dev/null
+++ b/app-misc/tkpasman/files/tkpasman-2.2a-gentoo.patch
@@ -0,0 +1,22 @@
+--- build.sh 2005-01-01 19:18:44.290385166 +0000
++++ build.sh 2005-01-01 19:22:45.846161383 +0000
+@@ -44,8 +44,8 @@
+ #
+ # Try to find wish8.3, tclsh8.3 and openssl
+ #
+-WISH=`FIND "$WISH" "" wish8.4 wish8.3 wish`
+-TCLSH=`FIND "$TCLSH" "" tclsh8.4 tclsh8.3 tclsh`
++WISH=`FIND "$WISH" "" wish wish8.4 wish8.3`
++TCLSH=`FIND "$TCLSH" "" tclsh tclsh8.4 tclsh8.3`
+ OPENSSL=`FIND "$OPENSSL" "$OPENSSL_SEARCH_PATH" openssl ssl`
+
+ #
+@@ -88,7 +88,7 @@
+ if test "$USE_OPENSSL" = "true" -a -x "$OPENSSL"
+ then
+ echo "Found OpenSSL program: $OPENSSL"
+- ENC=`$OPENSSL list-cipher-commands|sort|egrep "^($ENC)\$"|head -1`
++ ENC=`$OPENSSL list-cipher-commands|sort|egrep "^($ENC)\$"|head -n 1`
+ if test -z "$ENC"
+ then
+ echo "Could not find a suitable encryption algorithm."
diff --git a/app-misc/tkpasman/metadata.xml b/app-misc/tkpasman/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-misc/tkpasman/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-misc/tkpasman/tkpasman-2.2b.ebuild b/app-misc/tkpasman/tkpasman-2.2b.ebuild
new file mode 100644
index 000000000000..d731fe173f99
--- /dev/null
+++ b/app-misc/tkpasman/tkpasman-2.2b.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+MY_P="TkPasMan-${PV}"
+
+DESCRIPTION="A useful and reliable personal password manager, written in Tcl/Tk"
+HOMEPAGE="http://www.xs4all.nl/~wbsoft/linux/tkpasman.html"
+SRC_URI="http://www.xs4all.nl/~wbsoft/linux/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="ssl"
+
+DEPEND="
+ >=dev-lang/tcl-8.3:0=
+ >=dev-lang/tk-8.3:0="
+RDEPEND="${DEPEND}
+ ssl? ( dev-libs/openssl )
+ "
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2a-gentoo.patch
+
+ if use ssl; then
+ sed -i "s:^USE_OPENSSL=true:USE_OPENSSL=false:g" config || die
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README ChangeLog TODO WARNING INSTALL
+}