summaryrefslogtreecommitdiff
path: root/app-misc/tkpasman/tkpasman-2.2b.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tkpasman/tkpasman-2.2b.ebuild')
-rw-r--r--app-misc/tkpasman/tkpasman-2.2b.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/app-misc/tkpasman/tkpasman-2.2b.ebuild b/app-misc/tkpasman/tkpasman-2.2b.ebuild
index d731fe173f99..009b2731e9b5 100644
--- a/app-misc/tkpasman/tkpasman-2.2b.ebuild
+++ b/app-misc/tkpasman/tkpasman-2.2b.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils
+EAPI=7
MY_P="TkPasMan-${PV}"
@@ -20,13 +18,17 @@ DEPEND="
>=dev-lang/tcl-8.3:0=
>=dev-lang/tk-8.3:0="
RDEPEND="${DEPEND}
- ssl? ( dev-libs/openssl )
+ ssl? ( dev-libs/openssl:0= )
"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2a-gentoo.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.2a-gentoo.patch
+ default
if use ssl; then
sed -i "s:^USE_OPENSSL=true:USE_OPENSSL=false:g" config || die