summaryrefslogtreecommitdiff
path: root/app-misc/solaar/solaar-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/solaar/solaar-9999.ebuild')
-rw-r--r--app-misc/solaar/solaar-9999.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-misc/solaar/solaar-9999.ebuild b/app-misc/solaar/solaar-9999.ebuild
new file mode 100644
index 000000000000..6b0376ffc089
--- /dev/null
+++ b/app-misc/solaar/solaar-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit linux-info udev xdg distutils-r1
+
+DESCRIPTION="A Linux device manager for Logitech's Unifying Receiver peripherals"
+HOMEPAGE="https://pwr-solaar.github.io/Solaar/"
+if [[ ${PV} =~ 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pwr-Solaar/Solaar"
+else
+ SRC_URI="https://github.com/pwr-Solaar/Solaar/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S="${WORKDIR}"/Solaar-${PV} # hopefully upstream fixes this in future packaging
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="
+ acct-group/plugdev
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/pyudev-0.13[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]"
+
+CONFIG_CHECK="~HID_LOGITECH_DJ ~HIDRAW"
+
+python_prepare_all() {
+ # don't autostart (bug #494608)
+ sed -i '/yield autostart_path/d' setup.py || die
+
+ # grant plugdev group rw access
+ sed -i 's/#MODE=/MODE=/' rules.d/42-logitech-unify-permissions.rules || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ udev_dorules rules.d/*.rules
+
+ dodoc docs/devices.md
+ if use doc; then
+ dodoc -r docs/*
+ fi
+}