summaryrefslogtreecommitdiff
path: root/app-misc/rtlamr/rtlamr-0.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/rtlamr/rtlamr-0.9.1.ebuild')
-rw-r--r--app-misc/rtlamr/rtlamr-0.9.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/app-misc/rtlamr/rtlamr-0.9.1.ebuild b/app-misc/rtlamr/rtlamr-0.9.1.ebuild
new file mode 100644
index 000000000000..79ac536bfedc
--- /dev/null
+++ b/app-misc/rtlamr/rtlamr-0.9.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN=github.com/bemasher/rtlamr
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="software defined radio receiver for utility smart meters"
+HOMEPAGE="https://github.com/bemasher/rtlamr"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_install() {
+ dobin ${PN}
+ dodoc src/${EGO_PN}/*.md src/${EGO_PN}/*.csv
+}