summaryrefslogtreecommitdiff
path: root/app-misc/realpath/realpath-1.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/realpath/realpath-1.18.ebuild')
-rw-r--r--app-misc/realpath/realpath-1.18.ebuild38
1 files changed, 25 insertions, 13 deletions
diff --git a/app-misc/realpath/realpath-1.18.ebuild b/app-misc/realpath/realpath-1.18.ebuild
index dcaeab4fe8b0..c982935ecdbd 100644
--- a/app-misc/realpath/realpath-1.18.ebuild
+++ b/app-misc/realpath/realpath-1.18.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils flag-o-matic multilib prefix toolchain-funcs
+inherit flag-o-matic prefix
DESCRIPTION="Return the canonicalized absolute pathname"
HOMEPAGE="http://packages.debian.org/unstable/utils/realpath"
@@ -13,14 +13,21 @@ SRC_URI="
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="nls"
RDEPEND="
nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
nls? ( sys-devel/gettext )
- elibc_mintlib? ( virtual/libiconv )"
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.17-build.patch
+ "${FILESDIR}"/${PN}-1.14-no-po4a.patch
+ "${FILESDIR}"/${PN}-1.15-prefix.patch
+)
src_unpack() {
unpack ${PN}_${PV}.tar.gz
@@ -36,18 +43,22 @@ src_unpack() {
}
src_prepare() {
- use nls || epatch "${FILESDIR}"/${PN}-1.16-nonls.patch
- epatch \
- "${FILESDIR}"/${PN}-1.17-build.patch \
- "${FILESDIR}"/${PN}-1.14-no-po4a.patch \
- "${FILESDIR}"/${PN}-1.15-prefix.patch
+ if ! use nls ; then
+ eapply "${FILESDIR}"/${PN}-1.16-nonls.patch
+ fi
+
+ default
+
+ # Don't compress man pages
+ sed -i -e 's:gzip -9f:true:' common.mk || die
+
eprefixify common.mk
}
src_compile() {
tc-export CC
- use nls && use !elibc_glibc && append-libs -lintl
- [[ ${CHOST} == *-mint* ]] && append-libs "-liconv"
+
+ use nls && ! use elibc_glibc && append-libs -lintl
local subdir
for subdir in src man $(usex nls po ''); do
@@ -61,12 +72,13 @@ src_install() {
SUBDIRS="src man $(usex nls po '')" \
DESTDIR="${D}" \
install
+
newdoc debian/changelog ChangeLog.debian
if use nls; then
local dir
for dir in "${WORKDIR}"/deb/usr/share/man/*; do
- [ -f "${dir}"/man1/realpath.1 ] || continue
+ [[ -f "${dir}"/man1/realpath.1 ]] || continue
newman "${dir}"/man1/realpath.1 realpath.${dir##*/}.1
done
fi