summaryrefslogtreecommitdiff
path: root/app-misc/realpath/files/realpath-1.17-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/realpath/files/realpath-1.17-build.patch')
-rw-r--r--app-misc/realpath/files/realpath-1.17-build.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/realpath/files/realpath-1.17-build.patch b/app-misc/realpath/files/realpath-1.17-build.patch
new file mode 100644
index 000000000000..c4a8b3dfc9b9
--- /dev/null
+++ b/app-misc/realpath/files/realpath-1.17-build.patch
@@ -0,0 +1,43 @@
+--- a/common.mk
++++ b/common.mk
+@@ -33,16 +33,9 @@
+ applicationsdir := $(prefix)/share/applications
+
+ PERL := /usr/bin/perl
+-CC := gcc
+-CFLAGS += $(CPPFLAGS) -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Werror -g -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
+-LIBS :=
+-
+-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+- CFLAGS += -O0
+-else
+- CFLAGS += -O2
+-endif
+-
++CC ?= gcc
++CFLAGS += $(CPPFLAGS) -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
++LIBS +=
+
+ # determine our version number
+ ifndef VERSION
+@@ -58,9 +51,6 @@
+ unexport CDPATH ENV
+
+ ifdef DESTDIR
+- ifneq ($(DESTDIR),$(abspath $(DESTDIR)))
+- $(error DESTDIR "$(DESTDIR)" is not an absolute path)
+- endif
+ override ddirshort := DESTDIR
+ export ddirshort
+ endif
+@@ -108,7 +99,9 @@
+ esac; fi;
+ endef
+ else
+- msg := :
++ define msg
++ :
++ endef
+ endif
+
+ msgprefix := *$(subst * ,*,$(wordlist 1,$(MAKELEVEL),* * * * * * * * * * * * * * * * * *))