summaryrefslogtreecommitdiff
path: root/app-misc/ranger/ranger-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ranger/ranger-9999.ebuild')
-rw-r--r--app-misc/ranger/ranger-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-misc/ranger/ranger-9999.ebuild b/app-misc/ranger/ranger-9999.ebuild
index caed3a6516e3..2a728ea15449 100644
--- a/app-misc/ranger/ranger-9999.ebuild
+++ b/app-misc/ranger/ranger-9999.ebuild
@@ -2,10 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="ncurses"
-inherit distutils-r1
+inherit distutils-r1 xdg
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/ranger/ranger.git"
@@ -32,6 +32,8 @@ src_prepare() {
}
pkg_postinst() {
+ xdg_pkg_postinst
+
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "Ranger has many optional dependencies to support enhanced file previews."
elog "See the README or homepage for more details."