summaryrefslogtreecommitdiff
path: root/app-misc/qcma/qcma-0.4.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/qcma/qcma-0.4.1-r2.ebuild')
-rw-r--r--app-misc/qcma/qcma-0.4.1-r2.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/app-misc/qcma/qcma-0.4.1-r2.ebuild b/app-misc/qcma/qcma-0.4.1-r2.ebuild
index 011ad13717ee..d6c461d3cc9c 100644
--- a/app-misc/qcma/qcma-0.4.1-r2.ebuild
+++ b/app-misc/qcma/qcma-0.4.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit qmake-utils
+inherit qmake-utils xdg-utils
DESCRIPTION="Cross-platform content manager assistant for the PS Vita"
HOMEPAGE="https://github.com/codestation/qcma"
@@ -51,3 +51,15 @@ src_install() {
insinto /usr/share/${PN}/translations
doins common/resources/translations/${PN}_*.qm
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}