summaryrefslogtreecommitdiff
path: root/app-misc/openrgb/openrgb-0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/openrgb/openrgb-0.9.ebuild')
-rw-r--r--app-misc/openrgb/openrgb-0.9.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/app-misc/openrgb/openrgb-0.9.ebuild b/app-misc/openrgb/openrgb-0.9.ebuild
index 9c15691b3b6b..72260835c3d0 100644
--- a/app-misc/openrgb/openrgb-0.9.ebuild
+++ b/app-misc/openrgb/openrgb-0.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -63,10 +63,19 @@ src_configure() {
# > warning: ‘-pipe’ ignored because ‘-save-temps’ specified
filter-flags -pipe
+ # cpp-httplib >=0.16.0 changed the library name from "httplib" to "cpp-httplib".
+ # See bug: https://bugs.gentoo.org/934576
+ local -a libs=()
+ if has_version "<dev-cpp/cpp-httplib-0.16.0" ; then
+ libs+=( -lhttplib )
+ else
+ libs+=( -lcpp-httplib )
+ fi
+
eqmake5 \
INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann" \
DEFINES+="OPENRGB_EXTRA_PLUGIN_DIRECTORY=\\\\\"\\\"${EPREFIX}/usr/$(get_libdir)/OpenRGB/plugins\\\\\"\\\"" \
- LIBS+=-lhttplib
+ LIBS+="${libs[@]}"
}
src_install() {