summaryrefslogtreecommitdiff
path: root/app-misc/ondir/ondir-0.2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ondir/ondir-0.2.4.ebuild')
-rw-r--r--app-misc/ondir/ondir-0.2.4.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-misc/ondir/ondir-0.2.4.ebuild b/app-misc/ondir/ondir-0.2.4.ebuild
index 2f51ec18dee6..e3c9190d013a 100644
--- a/app-misc/ondir/ondir-0.2.4.ebuild
+++ b/app-misc/ondir/ondir-0.2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,15 +22,17 @@ src_prepare() {
default
sed -i \
-e "s:\(/man/.*$\):/share\1:g" \
- -e "s:-g:${CFLAGS}:" Makefile || die "sed Makefile failed"
+ -e "s#^CFLAGS=\(.*\)#CFLAGS= \1 ${CFLAGS}#g;" \
+ -e "s#^LDFLAGS=\(.*\)#LDFLAGS= \1 ${LDFLAGS}#g;" \
+ -i Makefile || die "sed Makefile failed"
}
src_compile() {
emake \
CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
PREFIX="${EPREFIX}/usr" \
- CONF="${EPREFIX}/etc/ondirrc" \
- LDFLAGS="${LDFLAGS}"
+ CONF="${EPREFIX}/etc/ondirrc"
}
src_install() {