summaryrefslogtreecommitdiff
path: root/app-misc/mvcase/mvcase-0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mvcase/mvcase-0.1-r1.ebuild')
-rw-r--r--app-misc/mvcase/mvcase-0.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/mvcase/mvcase-0.1-r1.ebuild b/app-misc/mvcase/mvcase-0.1-r1.ebuild
new file mode 100644
index 000000000000..817386ef3781
--- /dev/null
+++ b/app-misc/mvcase/mvcase-0.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A modified version of mv, used to convert filenames to lower/upper case"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/utils/file"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/file/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-libs/shhopt"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-includes.patch \
+ "${FILESDIR}"/${P}-flags.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin mvcase || die
+ doman mvcase.1
+ dodoc INSTALL
+}