summaryrefslogtreecommitdiff
path: root/app-misc/mc/mc-4.8.31.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mc/mc-4.8.31.ebuild')
-rw-r--r--app-misc/mc/mc-4.8.31.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/app-misc/mc/mc-4.8.31.ebuild b/app-misc/mc/mc-4.8.31.ebuild
index 5981d616172c..8b8437c5c57f 100644
--- a/app-misc/mc/mc-4.8.31.ebuild
+++ b/app-misc/mc/mc-4.8.31.ebuild
@@ -6,17 +6,18 @@ EAPI=8
inherit autotools flag-o-matic
MY_P="${P/_/-}"
-SRC_URI="http://ftp.midnight-commander.org/${MY_P}.tar.xz"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
-
DESCRIPTION="GNU Midnight Commander is a text based file manager"
HOMEPAGE="https://midnight-commander.org"
+SRC_URI="http://ftp.midnight-commander.org/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="+edit gpm nls sftp +slang spell test unicode X"
REQUIRED_USE="spell? ( edit )"
+RESTRICT="!test? ( test )"
DEPEND="
>=dev-libs/glib-2.30.0:2
@@ -34,8 +35,12 @@ DEPEND="
x11-libs/libSM
)
"
-RDEPEND="${DEPEND}
- spell? ( app-dicts/aspell-en )"
+
+RDEPEND="
+ ${DEPEND}
+ spell? ( app-dicts/aspell-en )
+"
+
BDEPEND="
app-arch/xz-utils
virtual/pkgconfig
@@ -43,10 +48,6 @@ BDEPEND="
test? ( dev-libs/check )
"
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${MY_P}"
-
PATCHES=(
"${FILESDIR}"/${PN}-4.8.26-ncurses-mouse.patch
"${FILESDIR}"/${PN}-4.8.29-gentoo-tools.patch
@@ -61,8 +62,11 @@ QA_CONFIG_IMPL_DECL_SKIP=(
src_prepare() {
default
- # Bug #906194
- use elibc_musl && eapply "${FILESDIR}"/${PN}-4.8.30-musl-tests.patch
+ # Bug #906194, #922483
+ if use elibc_musl; then
+ eapply "${FILESDIR}"/${PN}-4.8.30-musl-tests.patch
+ eapply "${FILESDIR}"/${PN}-4.8.31-musl-tests.patch
+ fi
eautoreconf
}
@@ -105,6 +109,7 @@ src_test() {
# information.
CK_FORK=no emake check VERBOSE=1
}
+
src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS NEWS README