summaryrefslogtreecommitdiff
path: root/app-misc/logserial/files/logserial-0.4.2-gentoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/logserial/files/logserial-0.4.2-gentoo.patch')
-rw-r--r--app-misc/logserial/files/logserial-0.4.2-gentoo.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/logserial/files/logserial-0.4.2-gentoo.patch b/app-misc/logserial/files/logserial-0.4.2-gentoo.patch
new file mode 100644
index 000000000000..dd594e34f76a
--- /dev/null
+++ b/app-misc/logserial/files/logserial-0.4.2-gentoo.patch
@@ -0,0 +1,30 @@
+diff -ur logserial-0.4.2.orig/Makefile logserial-0.4.2/Makefile
+--- logserial-0.4.2.orig/Makefile 2003-04-12 19:41:07.000000000 +0300
++++ logserial-0.4.2/Makefile 2009-07-21 19:39:18.000000000 +0300
+@@ -5,22 +5,20 @@
+ # FUNCTION:
+ # Makefile for logserial
+
+-CC=gcc
++CC ?= gcc
+
+ NAME=logserial
+ VERSION=0.4.2
+
+ OBJS= logserial.o sysdep1.o
+
+-OPTIMIZE= -O3 -m486 -Wall -D_POSIX -D_SYSV -D_SELECT -D_HAVE_MACROS
+-DEBUG_FLAGS= #-g
+-
+-CFLAGS= $(DEBUG_FLAGS) $(OPTIMIZE)
++CFLAGS += -Wall
++CPPFLAGS += -D_POSIX -D_SYSV -D_SELECT -D_HAVE_MACROS
+
+ all: $(NAME)
+
+ $(NAME): $(OBJS)
+- $(CC) $(CFLAGS) -o $(NAME) $(OBJS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(CPPFLAGS) -o $(NAME) $(OBJS)
+
+ $(NAME).o: $(NAME).c
+