summaryrefslogtreecommitdiff
path: root/app-misc/ledit/ledit-2.03.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ledit/ledit-2.03.ebuild')
-rw-r--r--app-misc/ledit/ledit-2.03.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/app-misc/ledit/ledit-2.03.ebuild b/app-misc/ledit/ledit-2.03.ebuild
index caec36f62406..4810b328c9a0 100644
--- a/app-misc/ledit/ledit-2.03.ebuild
+++ b/app-misc/ledit/ledit-2.03.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -18,15 +18,12 @@ RDEPEND="${DEPEND}"
SLOT="0"
LICENSE="BSD"
KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+RESTRICT="!ocamlopt? ( strip )"
src_compile() {
emake -j1 all
if use ocamlopt; then
emake -j1 ledit.opt
- else
- # If using bytecode we dont want to strip the binary as it would remove the
- # bytecode and only leave ocamlrun...
- export STRIP_MASK="*/bin/*"
fi
}