summaryrefslogtreecommitdiff
path: root/app-misc/jpipe/jpipe-0.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/jpipe/jpipe-0.2.0-r1.ebuild')
-rw-r--r--app-misc/jpipe/jpipe-0.2.0-r1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/app-misc/jpipe/jpipe-0.2.0-r1.ebuild b/app-misc/jpipe/jpipe-0.2.0-r1.ebuild
index ada99312a317..ac4e8aa09cd1 100644
--- a/app-misc/jpipe/jpipe-0.2.0-r1.ebuild
+++ b/app-misc/jpipe/jpipe-0.2.0-r1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
GO_OPTIONAL=1
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{9,10,11} )
+PYTHON_COMPAT=( python3_{10,11} )
+DISTUTILS_USE_PEP517=setuptools
inherit go-module distutils-r1 pypi
@@ -21,7 +22,7 @@ RESTRICT+=" test"
IUSE="jpp-symlink jp-symlink python test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
-BDEPEND="
+BDEPEND="${DISTUTILS_DEPS}
!python? (
app-arch/unzip
>=dev-lang/go-1.12
@@ -40,6 +41,8 @@ RDEPEND="
)
"
+distutils_enable_tests pytest
+
src_unpack() {
if use python; then
default