summaryrefslogtreecommitdiff
path: root/app-misc/jdupes/jdupes-1.26.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/jdupes/jdupes-1.26.1.ebuild')
-rw-r--r--app-misc/jdupes/jdupes-1.26.1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/app-misc/jdupes/jdupes-1.26.1.ebuild b/app-misc/jdupes/jdupes-1.26.1.ebuild
deleted file mode 100644
index 11eb2fbd9836..000000000000
--- a/app-misc/jdupes/jdupes-1.26.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="Identify duplicate files on the filesystem"
-HOMEPAGE="https://github.com/jbruchon/jdupes"
-if [[ "${PV}" == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/jbruchon/jdupes.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/jbruchon/jdupes/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64"
-fi
-LICENSE="MIT"
-SLOT="0"
-
-# Please keep a careful eye on the minimum libjoycode version! (Just pick
-# latest released at the time if necessary.)
-DEPEND=">=dev-libs/libjodycode-3.0"
-RDEPEND="${DEPEND}"
-
-IUSE="+dedupe hardened"
-
-# missing test.sh script
-# https://github.com/jbruchon/jdupes/issues/191
-RESTRICT="test"
-
-src_prepare() {
- sed -i -e '/PREFIX/s/=/?=/' Makefile || die
- default
-}
-
-src_compile() {
- tc-export CC
- local myconf=(
- $(usex dedupe 'ENABLE_DEDUPE=1' '')
- $(usex hardened 'HARDEN=1' '')
- )
- emake ${myconf[@]}
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
- einstalldocs
-}