summaryrefslogtreecommitdiff
path: root/app-misc/hivex
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/hivex')
-rw-r--r--app-misc/hivex/Manifest4
-rw-r--r--app-misc/hivex/hivex-1.3.18.ebuild26
-rw-r--r--app-misc/hivex/hivex-1.3.20.ebuild119
3 files changed, 136 insertions, 13 deletions
diff --git a/app-misc/hivex/Manifest b/app-misc/hivex/Manifest
index 100c2426b43a..cdd587302914 100644
--- a/app-misc/hivex/Manifest
+++ b/app-misc/hivex/Manifest
@@ -1,3 +1,5 @@
DIST hivex-1.3.18.tar.gz 1542133 BLAKE2B 961d0797770a2bd3176ce288a509fab8685de91317d55f05e5295f9f56fd54c31acb64847e0cbb6a6074627ccbdfdf35bd0d35150beb7746a8b3de9128ac24e3 SHA512 1851351118921e81df9e505f90d00048a178572c2edd3de40194a69915176bdb615e2eb5afea408d57063e98257c8d1e3d0cd6730407153892cc9e3befc4aa3a
-EBUILD hivex-1.3.18.ebuild 1954 BLAKE2B f8f37ab6842487f92cd27d46dd8fcb1314d9744d7102ed230bb1f47b01fc6d22212193fc8eb44079253efbae95525485436ad7c6d8ec382fc31840add3b8303e SHA512 1c155dc9e098b98db0ef7dedb6916c9677ebc576ebeccb18f719ac7dbb422f3f104dd8c44e4cee45f48a8fb4be5313e8f3bff14ab1fd759b0574bdbd46af6173
+DIST hivex-1.3.20.tar.gz 1727498 BLAKE2B db6448242fc4b72d75cc7234a49e146cb165b1b9b9e2e72fb2a05be37cbb1d8ca865ccc51c4d2d50199e69cae2d870743ecd41534290e9a100bb268c2437ee22 SHA512 366e84c2a13ff53c70036df60db6e2b469cd06e3405761df73c47978b4fa0245246a1ea912aa5852b1272221d55c6c100b40b00e4c9a6f5668d12ff7f93c787a
+EBUILD hivex-1.3.18.ebuild 1996 BLAKE2B 4337c1440a1e9bc881dc8c9a7bdd8b9e009abfa19050ea287df50a7bb6da805877c917f69279fea9446dae62563bf7039ddbc817168c454c729d68eaadee7f49 SHA512 ef2f9d1079c4ab579987ea12211eaf6d6718c657b7e560ed03fc5990fdeff5f7dab279534aa8525a591f1266ad2e840cb1518e9d461e8901b64d6b0723ce16d6
+EBUILD hivex-1.3.20.ebuild 2136 BLAKE2B 80812806c43ad9638bdad1033c44234dd857cadbebab6bcdedea5c27530a661588dadc9a98bdfb6510b7d5202433b5d4a8741d69fa81b289cb8cd06985e00de4 SHA512 832d8b149c79ac7995cf4ed3a0db3c56000651b0906b40dd96bc746ad79753ba12b2dda912eae4cd5716eb40bbe5952922bc307ee75e0cd757a1bafef24b7163
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-misc/hivex/hivex-1.3.18.ebuild b/app-misc/hivex/hivex-1.3.18.ebuild
index f1c6db65034f..cace53ff05ef 100644
--- a/app-misc/hivex/hivex-1.3.18.ebuild
+++ b/app-misc/hivex/hivex-1.3.18.ebuild
@@ -8,7 +8,7 @@ RUBY_OPTIONAL=yes
PYTHON_COMPAT=( python3_{7,8,9} )
-inherit eutils perl-module ruby-ng python-single-r1
+inherit l10n perl-module ruby-ng python-single-r1
DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
HOMEPAGE="https://libguestfs.org"
@@ -20,27 +20,28 @@ KEYWORDS="~amd64 ~x86"
IUSE="ocaml readline +perl python test ruby"
RDEPEND="
+ dev-libs/libxml2:2
virtual/libiconv
virtual/libintl
- dev-libs/libxml2:2
ocaml? ( dev-lang/ocaml[ocamlopt]
dev-ml/findlib[ocamlopt]
)
- readline? ( sys-libs/readline:0 )
perl? (
dev-lang/perl:=
dev-perl/IO-stringy
)
- ruby? ( $(ruby_implementations_depend) )
python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0 )
+ ruby? ( $(ruby_implementations_depend) )
"
DEPEND="${RDEPEND}
perl? (
- test? ( dev-perl/Pod-Coverage
- dev-perl/Test-Pod-Coverage )
- )
- "
+ test? (
+ dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage
+ )
+ )"
ruby_add_bdepend "ruby? ( dev-ruby/rake
virtual/rubygems
@@ -62,11 +63,11 @@ pkg_setup() {
src_unpack() {
default
- cp -prlP "${WORKDIR}/${P}" "${WORKDIR}"/all
+ cp -prlP "${WORKDIR}/${P}" "${WORKDIR}"/all || die
}
src_configure() {
- ruby-ng_src_configure
+ use ruby && ruby-ng_src_configure
if use perl; then
pushd perl
@@ -90,7 +91,8 @@ src_configure() {
src_compile() {
default
- ruby-ng_src_compile
+
+ use ruby && ruby-ng_src_compile
}
src_install() {
@@ -101,7 +103,7 @@ src_install() {
python_optimize
fi
- ruby-ng_src_install
+ use ruby && ruby-ng_src_install
if use perl; then
perl_delete_localpod
diff --git a/app-misc/hivex/hivex-1.3.20.ebuild b/app-misc/hivex/hivex-1.3.20.ebuild
new file mode 100644
index 000000000000..3fd24d446ca2
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.20.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+RUBY_OPTIONAL=yes
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit l10n perl-module ruby-ng python-single-r1
+
+DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
+HOMEPAGE="https://libguestfs.org"
+SRC_URI="https://libguestfs.org/download/${PN}/${P}.tar.gz"
+S="${WORKDIR}/${P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocaml readline +perl python test ruby"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ virtual/libiconv
+ virtual/libintl
+ ocaml? (
+ dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ perl? (
+ dev-lang/perl:=
+ dev-perl/IO-stringy
+ )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0 )
+ ruby? ( $(ruby_implementations_depend) )
+"
+DEPEND="${RDEPEND}
+ perl? (
+ test? (
+ dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage
+ )
+ )"
+
+ruby_add_bdepend "ruby? ( dev-ruby/rake
+ virtual/rubygems
+ dev-ruby/rdoc )"
+ruby_add_rdepend "ruby? ( virtual/rubygems )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ ruby? ( || ( $(ruby_get_use_targets) ) )"
+
+DOCS=( README )
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_unpack() {
+ default
+ cp -prlP "${WORKDIR}/${P}" "${WORKDIR}"/all || die
+}
+
+src_configure() {
+ use ruby && ruby-ng_src_configure
+
+ if use perl; then
+ pushd perl || die
+ perl-module_src_configure
+ popd || die
+ fi
+
+ local myeconfargs=(
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ --enable-nls
+ --disable-ruby
+ $(use_enable python)
+ --disable-rpath
+ --disable-static
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ use ruby && ruby-ng_src_compile
+}
+
+src_install() {
+ strip-linguas -i po
+
+ emake install DESTDIR="${ED}" "LINGUAS=""${LINGUAS}"""
+
+ if use python; then
+ python_optimize
+ fi
+
+ if use ruby; then
+ ruby-ng_src_install
+ fi
+
+ if use perl; then
+ perl_delete_localpod
+
+ # Workaround Build.PL for now (see libguestfs too)
+ doman "${ED}"/usr/man/man3/*
+ rm -rf "${ED}"/usr/man || die
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}