summaryrefslogtreecommitdiff
path: root/app-misc/grc/grc-1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/grc/grc-1.5.ebuild')
-rw-r--r--app-misc/grc/grc-1.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/grc/grc-1.5.ebuild b/app-misc/grc/grc-1.5.ebuild
new file mode 100644
index 000000000000..b20233047ba5
--- /dev/null
+++ b/app-misc/grc/grc-1.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit eutils python-r1
+
+DESCRIPTION="Generic Colouriser beautifies your logfiles or output of commands"
+HOMEPAGE="http://kassiopeia.juls.savba.sk/~garabik/software/grc.html"
+SRC_URI="http://kassiopeia.juls.savba.sk/~garabik/software/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.4-support-more-files.patch \
+ "${FILESDIR}"/${PN}-1.4-ipv6.patch
+}
+
+src_install() {
+ python_foreach_impl python_doscript grc grcat
+
+ insinto /usr/share/grc
+ doins conf.* "${FILESDIR}"/conf.*
+
+ insinto /etc
+ doins grc.conf
+
+ dodoc README INSTALL TODO debian/changelog CREDITS
+ doman grc.1 grcat.1
+}