summaryrefslogtreecommitdiff
path: root/app-misc/gramps
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/gramps')
-rw-r--r--app-misc/gramps/Manifest2
-rw-r--r--app-misc/gramps/gramps-5.1.4.ebuild112
2 files changed, 114 insertions, 0 deletions
diff --git a/app-misc/gramps/Manifest b/app-misc/gramps/Manifest
index bf254aff5c86..a112a8aedbde 100644
--- a/app-misc/gramps/Manifest
+++ b/app-misc/gramps/Manifest
@@ -1,4 +1,6 @@
AUX gramps-5.1.3-test_locale.patch 1195 BLAKE2B 1b1aeb08b90bff9db9d028499428efa60a16b48597bcf466c07a77e3f658c8550eca84b899047d1bc6e20eb26e8dfab9637ae7aced1b99167466ea6c51707132 SHA512 70daee9afdce0f939ad3cec094fb4004f5c162e6b49849f83486db5baec074a8673d7a6096a367279019712a11f0b40e827f6cb3019e7dc3cc6bad327fee35ec
DIST gramps-5.1.3.tar.gz 17352457 BLAKE2B 8356e29d4e9e2ee78f0f09e54db8f77b2db991652f2c6b2fdc742b8f2e160a2c9c2b7df1a43c34e5d05b12b540e88cd8572fe89cfbb3a1ecb6df650a39ac0651 SHA512 045d5dd6aac4745ce527624657bbee25b9130e63b1b66bdd6a8409cdc876f1f3a4a6c0435d433a62bfffb723f6ac66d93829b79fc12c8768694c266b7a3b82cc
+DIST gramps-5.1.4.tar.gz 17425713 BLAKE2B 9b3761906b70ed6b85112e502290013cf421669418355ed0dc54d00adbcc2af4cd74c596bacaad50cdac6457e7a3b7675d4afb7b471fd471af8b7a6adae3ad82 SHA512 f43fc250142968331db1875260577e022898cff2d1453ee6b74be760d798b75cfdf93492d8d823dbb094da2ddd96a4f249e813c603e7cd9d0585641424284734
EBUILD gramps-5.1.3.ebuild 3423 BLAKE2B 50c35c845943c62d32179ca86971636e459f2224ebb81f23d342242d682f8ac040fbd6d2b65bfecb2a280496161cd2c379c9cc11f9d64df11efc1f1769961e1f SHA512 4ae9b62f164d9ffc977751cefd8d96d4e1987c05bb384b9fd73bfb23a56f82ffae630468000881c24dfdf975165ad420bcb4c7d05ad189dad780be7437d66919
+EBUILD gramps-5.1.4.ebuild 3487 BLAKE2B e74e3d579630090d44a827088a8acf77a2f5d3c492dd858548abef60c548d4bea745213a3957bc11b42f785aceb805cf35744f028d77bc70249db87d65f1b7c7 SHA512 fea05cfeae5ce519eb8c20b0d0e397246b62851ab76dea52af61cf2fd2d7ce209b4cad313dce25fa732d54c95eb43cd53ef5d0ab96df7df442f108256437adef
MISC metadata.xml 5702 BLAKE2B 21c6b024222b3d4cc29ea388a8f16cbc158850ac5bb0ac32bd55205abfeb91d48d400be992f4f50c2af7e05b1c768e7916b7ff3db16eeea2b33dd294c27f7637 SHA512 e95b67c7b179bfd9bf280d9c8dfd69cc533562abf8b07a433a5c945cc76468f8f7d2097a218a406c71afe4a97ff8e8a790feec8b097c82ad24eed9b6ac8ec99e
diff --git a/app-misc/gramps/gramps-5.1.4.ebuild b/app-misc/gramps/gramps-5.1.4.ebuild
new file mode 100644
index 000000000000..6b2c20dec3ca
--- /dev/null
+++ b/app-misc/gramps/gramps-5.1.4.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="sqlite"
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Community genealogy program aiming to be both intuitive and feature-complete"
+HOMEPAGE="https://gramps-project.org/"
+SRC_URI="https://github.com/gramps-project/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb exif geo postscript +rcs +reports spell test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.12:3[cairo,${PYTHON_USEDEP}]
+ dev-python/pyicu[${PYTHON_USEDEP}]
+ berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
+ exif? ( >=media-libs/gexiv2-0.5[${PYTHON_USEDEP},introspection] )
+ ')
+ gnome-base/librsvg:2
+ >x11-libs/gtk+-3.14.8:3[introspection]
+ x11-libs/pango[introspection]
+ x11-misc/xdg-utils
+ reports? ( media-gfx/graphviz[postscript?] )
+ geo? ( >=sci-geosciences/osm-gps-map-1.1.0 )
+ spell? ( app-text/gtkspell:3[introspection] )
+ rcs? ( dev-vcs/rcs )
+"
+BDEPEND="test? ( ${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ ')
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.1.3-test_locale.patch
+)
+
+python_prepare_all() {
+ # Install documentation to the proper location. This can't be done
+ # easily with a patch because we substitute in the ${PF} variable,
+ # and that changes with every revision.
+ sed -i "s:share/doc/gramps:share/doc/${PF}:g" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ DISTUTILS_ARGS=(
+ --resourcepath=/usr/share
+ --no-compress-manpages
+ )
+}
+
+python_test() {
+ # Gramps builds just fine out of tree but it confuses its test suite.
+ # The following might be an ugly hack but at least it lets the tests
+ # run properly until either I or upstream have come up with something
+ # better. FIXME: test this when a new release comes out.
+ rm -rf "${S}/build" && ln -s "${BUILD_DIR}" "${S}"/build || \
+ die "Failed to symlink build directory to source directory"
+
+ # Set a sane default locale for the tests which do not explicitly set one.
+ local -x LC_ALL=C.UTF-8
+
+ # Note that as of 5.1.3, test failures do not actually propagate back
+ # to this function. For now this is fortunate because the test suite
+ # does not handle the absence of bsddb3 well, in the long run however
+ # this should be fixed.
+ esetup.py test || die
+}
+
+# Ugly hack to work around Bug #717922
+python_install() {
+ local DISTUTILS_ARGS=(
+ --resourcepath=/usr/share
+ --no-compress-manpages
+ build
+ )
+ distutils-r1_python_install
+ echo -n "${EPREFIX}/usr/share" > "${D}$(python_get_sitedir)/gramps/gen/utils/resource-path" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+
+ if use berkdb; then
+ ewarn "The BSDDB back-end in ${PN} has got known stability and data-corruption issues. It has been deprecated since version 5.1.0 and might be removed in 5.2.0."
+ ewarn "If you have any family trees in this format you are highly advised to convert them to SQLite, as described here:"
+ ewarn
+ ewarn "https://gramps-project.org/wiki/index.php/Gramps_5.1_Wiki_Manual_-_Manage_Family_Trees#Converting_a_BSDDB_Family_Tree_to_SQLite"
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}