summaryrefslogtreecommitdiff
path: root/app-misc/gramps/gramps-5.1.6-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/gramps/gramps-5.1.6-r2.ebuild')
-rw-r--r--app-misc/gramps/gramps-5.1.6-r2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-misc/gramps/gramps-5.1.6-r2.ebuild b/app-misc/gramps/gramps-5.1.6-r2.ebuild
index 21e33b40891f..2f8c17d56165 100644
--- a/app-misc/gramps/gramps-5.1.6-r2.ebuild
+++ b/app-misc/gramps/gramps-5.1.6-r2.ebuild
@@ -51,7 +51,9 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.1.6-pep517_setup.patch
)
-DISTUTILS_ARGS="--no-compress-manpages"
+DISTUTILS_ARGS=(
+ --no-compress-manpages
+)
distutils_enable_tests pytest
@@ -69,6 +71,13 @@ src_prepare() {
default
}
+python_install() {
+ distutils-r1_python_install
+
+ # setup.py option --resourcepath appears to have problems at the moment
+ echo -n "/usr/share" > "${ED}"$(python_get_sitedir)/${PN}/gen/utils/resource-path || die
+}
+
pkg_postinst() {
xdg_desktop_database_update
xdg_icon_cache_update