summaryrefslogtreecommitdiff
path: root/app-misc/freewvs/freewvs-0.1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/freewvs/freewvs-0.1.4.ebuild')
-rw-r--r--app-misc/freewvs/freewvs-0.1.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/freewvs/freewvs-0.1.4.ebuild b/app-misc/freewvs/freewvs-0.1.4.ebuild
new file mode 100644
index 000000000000..aad7b0efa8ca
--- /dev/null
+++ b/app-misc/freewvs/freewvs-0.1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9,10,11,12} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Scans filesystem for known vulnerable web applications"
+HOMEPAGE="https://freewvs.schokokeks.org/"
+
+LICENSE="0BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.md )
+
+pkg_postinst() {
+ einfo To use freewvs you need to run
+ einfo update-freewvsdb
+ einfo first. You should run this on a regular basis to update
+ einfo the web application data, e.g. via a cronjob.
+}
+
+# Only codingstyle and similar tests, require dependencies
+# not packaged in Gentoo
+RESTRICT="test"