summaryrefslogtreecommitdiff
path: root/app-misc/filebus
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/filebus')
-rw-r--r--app-misc/filebus/Manifest2
-rw-r--r--app-misc/filebus/filebus-0.3.5.ebuild9
2 files changed, 6 insertions, 5 deletions
diff --git a/app-misc/filebus/Manifest b/app-misc/filebus/Manifest
index e5a5802e933b..c4500840f157 100644
--- a/app-misc/filebus/Manifest
+++ b/app-misc/filebus/Manifest
@@ -1,3 +1,3 @@
DIST filebus-0.3.5.tar.gz 17373 BLAKE2B bd49f86e658bcc8dcdcc7cc0c5ca1a3c354a716137157753417b9b57294c14f058292650092e7e8bdb5563e041c009f36474508fb121e14487075cfc41b223bb SHA512 639b047be8fd3eba9cf97e57d7234f590aeb28e6e321195b435480ce0b334e14c236b888e79d14a824b16505e1c2d2c1fc04dd5d75b6f7ac1c8e9fbae6bf562f
-EBUILD filebus-0.3.5.ebuild 1337 BLAKE2B b5795c7a4987bd70902d988a7b1bb2a6083d9e05c78fab8f298022a83d13815ab6199484b7a8715ac7d99c9d204d8f6705f893857008cacc05c940e9e3782f61 SHA512 cba712fc8cfd2da35e25a7ab6235a853fe7255ce64c5a2722544471ff3b4d86ed10690c82d30c72b340387a50ebde699ebfafebd4a0db06f72f37cc408902b2f
+EBUILD filebus-0.3.5.ebuild 1388 BLAKE2B 09fd4aaf65f084ab8e2d96b122fa871cbf184278fe53ab90de58938e484b5e08fea2558a76391d085de5e14196b0883e8f7f2dc3b522bd07141319fa8f4ac7c0 SHA512 ab8089fc45cf3d0684acd5c14c8f8ba2fa80e1223b3b3001452a57c3e35a8b5b5bfdc97a7186b943fbe82210149c7645cf271cb667cc3165da7543a38e8b721b
MISC metadata.xml 344 BLAKE2B 5caade90b88d436416ff73af46b130b7b81e87f7c8850eac5eb6544432bec05da5c7d1f916f1f8306ff9dc13383dd6608667c8bc532712c57859ffd317fcde90 SHA512 4c172e9f8559f617647d0c6bf5b5408b53c5e26f9cfb96295584c594fcabfb768672c20ff4f16f4da738b391167aec2ea2f4929723f0167e8274df528c0bf561
diff --git a/app-misc/filebus/filebus-0.3.5.ebuild b/app-misc/filebus/filebus-0.3.5.ebuild
index c8eae8478dcd..71ab1c8994b0 100644
--- a/app-misc/filebus/filebus-0.3.5.ebuild
+++ b/app-misc/filebus/filebus-0.3.5.ebuild
@@ -1,9 +1,10 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{9,10,11} )
+PYTHON_COMPAT=( python3_{10,11,12} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
@@ -23,7 +24,7 @@ RDEPEND="
dev-python/filelock[${PYTHON_USEDEP}]
inotify? ( dev-python/watchdog[${PYTHON_USEDEP}] )
)"
-BDEPEND="${RDEPEND}"
+BDEPEND="${DISTUTILS_DEPS} ${RDEPEND}"
src_prepare() {
default