summaryrefslogtreecommitdiff
path: root/app-misc/fdutils/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/fdutils/files')
-rw-r--r--app-misc/fdutils/files/fdutils-5.5-superformat-snprintf.patch16
-rw-r--r--app-misc/fdutils/files/fdutils-5.5.20060227-r1-parallel.patch18
2 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/fdutils/files/fdutils-5.5-superformat-snprintf.patch b/app-misc/fdutils/files/fdutils-5.5-superformat-snprintf.patch
new file mode 100644
index 000000000000..49753478e5e6
--- /dev/null
+++ b/app-misc/fdutils/files/fdutils-5.5-superformat-snprintf.patch
@@ -0,0 +1,16 @@
+Fix of snprintf bug in upstream's 20081027 diff.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar --exclude '*.orig' --exclude '*~' fdutils-5.5-20060227.orig/src/superformat.c fdutils-5.5-20060227/src/superformat.c
+--- fdutils-5.5-20060227.orig/src/superformat.c 2019-03-17 14:46:44.051851597 -0700
++++ fdutils-5.5-20060227/src/superformat.c 2019-03-17 14:48:34.550873108 -0700
+@@ -1140,7 +1140,7 @@
+ if (verbosity >= 5)
+ printf("calling mformat\n");
+ if (use_2m)
+- snprintf(twom_buffer, 5, "-2 %2d", fd0.dsect);
++ snprintf(twom_buffer, 6, "-2 %2d", fd0.dsect);
+ else
+ twom_buffer[0]='\0';
+ snprintf(command_buffer, 79,
diff --git a/app-misc/fdutils/files/fdutils-5.5.20060227-r1-parallel.patch b/app-misc/fdutils/files/fdutils-5.5.20060227-r1-parallel.patch
new file mode 100644
index 000000000000..52c0a1357a59
--- /dev/null
+++ b/app-misc/fdutils/files/fdutils-5.5.20060227-r1-parallel.patch
@@ -0,0 +1,18 @@
+The Makefile implicit archive format ('Archives' in make.info) from, e.g.
+'libfdutils.a($(LIBFILES))' does not support parallel operations. Convert to
+parallel-safe structure.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+--- fdutils-5.5-20060227.orig/src/Makefile.in 2019-03-17 13:25:43.891918479 -0700
++++ fdutils-5.5-20060227/src/Makefile.in 2019-03-17 13:30:05.067424657 -0700
+@@ -67,7 +67,7 @@
+ lex.%.c: %.lex
+ lex -P$* $<
+
+-libfdutils.a: libfdutils.a($(LIBFILES))
+- ranlib libfdutils.a
++libfdutils.a: $(LIBFILES)
++ ar rcs $@ $^
+
+ floppycontrol.o getfdprm setfdprm: /usr/include/linux/fd.h