summaryrefslogtreecommitdiff
path: root/app-misc/egads/egads-0.9.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/egads/egads-0.9.5-r1.ebuild')
-rw-r--r--app-misc/egads/egads-0.9.5-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-misc/egads/egads-0.9.5-r1.ebuild b/app-misc/egads/egads-0.9.5-r1.ebuild
index 415f97ec2038..e6a0e21f3755 100644
--- a/app-misc/egads/egads-0.9.5-r1.ebuild
+++ b/app-misc/egads/egads-0.9.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,7 +28,8 @@ src_prepare() {
src_configure() {
econf \
--with-egads-datadir="${EGADS_DATADIR}" \
- --with-bindir=/usr/sbin
+ --with-bindir="${EPREFIX}"/usr/sbin \
+ --disable-static
}
src_compile() {
@@ -45,4 +46,6 @@ src_install() {
INCLUDEDIR="${D}"/usr/include
dodoc README* doc/*.txt doc/*.html
+
+ find "${ED}" -name '*.la' -delete || die
}