summaryrefslogtreecommitdiff
path: root/app-misc/dfshow/dfshow-0.9.1_beta.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/dfshow/dfshow-0.9.1_beta.ebuild')
-rw-r--r--app-misc/dfshow/dfshow-0.9.1_beta.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/dfshow/dfshow-0.9.1_beta.ebuild b/app-misc/dfshow/dfshow-0.9.1_beta.ebuild
new file mode 100644
index 000000000000..29830de4a64a
--- /dev/null
+++ b/app-misc/dfshow/dfshow-0.9.1_beta.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+MY_PV="${PV//_beta/-beta}"
+DESCRIPTION="DF-SHOW is a Unix-like rewrite of some of the applications from DF-EDIT"
+HOMEPAGE="https://github.com/roberthawdon/dfshow"
+SRC_URI="https://github.com/roberthawdon/dfshow/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libconfig
+ sys-libs/ncurses:0=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i 's/LDADD = -lncursesw -lm -lconfig/LDADD = -lncursesw -lm -lconfig -ltinfow/' Makefile.am ||
+ die "sed in Makefile.am failed"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newbashcomp "${S}/misc/auto-completion/bash/sf-completion.bash" sf-completion
+ newbashcomp "${S}/misc/auto-completion/bash/show-completion.bash" show-completion
+
+ insinto /usr/share/zsh/site-functions
+ doins "${S}/misc/auto-completion/zsh/_sf"
+ doins "${S}/misc/auto-completion/zsh/_show"
+}