summaryrefslogtreecommitdiff
path: root/app-misc/cadubi/cadubi-1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cadubi/cadubi-1.3.ebuild')
-rw-r--r--app-misc/cadubi/cadubi-1.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/cadubi/cadubi-1.3.ebuild b/app-misc/cadubi/cadubi-1.3.ebuild
new file mode 100644
index 000000000000..9e51a1ee8b47
--- /dev/null
+++ b/app-misc/cadubi/cadubi-1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An application that allows you to draw ASCII-Art images"
+HOMEPAGE="http://langworth.com/CadubiProject"
+SRC_URI="http://langworth.com/downloads/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ >=dev-perl/TermReadKey-2.21"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-helpfile.patch
+}
+
+src_install() {
+ dobin cadubi
+ insinto /usr/$(get_libdir)/${PN}
+ doins help.txt
+ dodoc README
+}