summaryrefslogtreecommitdiff
path: root/app-misc/boxes/files/boxes-2.3.0-ncurses-gentoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/boxes/files/boxes-2.3.0-ncurses-gentoo.patch')
-rw-r--r--app-misc/boxes/files/boxes-2.3.0-ncurses-gentoo.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/app-misc/boxes/files/boxes-2.3.0-ncurses-gentoo.patch b/app-misc/boxes/files/boxes-2.3.0-ncurses-gentoo.patch
new file mode 100644
index 000000000000..38e7117592e4
--- /dev/null
+++ b/app-misc/boxes/files/boxes-2.3.0-ncurses-gentoo.patch
@@ -0,0 +1,15 @@
+Gentoo splits ncurses into several independent libraries. Therefore this needs to be linked with more than just -lncurses.
+
+Pascal Jäger <pascal.jaeger@leimstift.de> (2024-02-19)
+
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -64,7 +64,7 @@ debug: flags_$(BOXES_PLATFORM) | $(OUT_DIR)
+ CFLAGS_ADDTL="-ggdb3 $(CFLAGS_ADDTL)" flags_$(BOXES_PLATFORM) $(BOXES_EXECUTABLE_NAME)
+
+ boxes: $(ALL_OBJ) | check_dir
+- $(CC) $(LDFLAGS) $^ -o $@ -lunistring -lpcre2-32 -lncurses
++ $(CC) $(LDFLAGS) $^ -o $@ -lunistring -lpcre2-32 $(shell pkg-config --libs ncurses)
+ if [ "$(STRIP)" = "true" ] ; then strip $@ ; fi
+
+ boxes.static: $(ALL_OBJ) | check_dir