summaryrefslogtreecommitdiff
path: root/app-misc/binwalk/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/binwalk/files')
-rw-r--r--app-misc/binwalk/files/2.3.3-tests.patch12
-rw-r--r--app-misc/binwalk/files/binwalk-2.2.0-disable-test-coverage.patch14
-rw-r--r--app-misc/binwalk/files/binwalk-2.3.3-syntax-fix.patch36
3 files changed, 0 insertions, 62 deletions
diff --git a/app-misc/binwalk/files/2.3.3-tests.patch b/app-misc/binwalk/files/2.3.3-tests.patch
deleted file mode 100644
index dd4f876c7777..000000000000
--- a/app-misc/binwalk/files/2.3.3-tests.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-reverted:
---- b/testing/tests/test_firmware_zip.py
-+++ a/testing/tests/test_firmware_zip.py
-@@ -10,6 +10,8 @@
- '''
- expected_results = [
- [0, 'Zip archive data, at least v1.0 to extract, name: dir655_revB_FW_203NA/'],
-+ [51, 'Zip archive data, at least v2.0 to extract, compressed size: 6395868, uncompressed size: 6422554, name: dir655_revB_FW_203NA/DIR655B1_FW203NAB02.bin'],
-+ [6395993, 'Zip archive data, at least v2.0 to extract, compressed size: 14243, uncompressed size: 61440, name: dir655_revB_FW_203NA/dir655_revB_release_notes_203NA.doc'],
- [6410581, 'End of Zip archive, footer length: 22'],
-
- ]
diff --git a/app-misc/binwalk/files/binwalk-2.2.0-disable-test-coverage.patch b/app-misc/binwalk/files/binwalk-2.2.0-disable-test-coverage.patch
deleted file mode 100644
index 5dd322ba6036..000000000000
--- a/app-misc/binwalk/files/binwalk-2.2.0-disable-test-coverage.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Avoid having to pull in dev-python/coverage test dep since we don't care about
-coverage.
-
---- binwalk-2.2.0/setup.py
-+++ binwalk-2.2.0/setup.py
-@@ -303,7 +303,7 @@
- os.chdir(testing_directory)
-
- # Run the tests
-- retval = nose.core.run(argv=['--exe','--with-coverage'])
-+ retval = nose.core.run(argv=['--exe'])
-
- sys.stdout.write("\n")
-
diff --git a/app-misc/binwalk/files/binwalk-2.3.3-syntax-fix.patch b/app-misc/binwalk/files/binwalk-2.3.3-syntax-fix.patch
deleted file mode 100644
index 5edd530b2293..000000000000
--- a/app-misc/binwalk/files/binwalk-2.3.3-syntax-fix.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-https://github.com/ReFirmLabs/binwalk/pull/585
-
-From bce53d1bb57c2e6dccf718147ebe9472779b7903 Mon Sep 17 00:00:00 2001
-From: Cameron Katri <me@cameronkatri.com>
-Date: Mon, 3 Jan 2022 15:20:39 -0500
-Subject: [PATCH] Fix SyntaxWarning message
-
-/usr/lib/python3/dist-packages/binwalk/modules/extractor.py:969: SyntaxWarning: "is" with a literal. Did you mean "=="?
- if child_pid is 0:
-/usr/lib/python3/dist-packages/binwalk/modules/extractor.py:984: SyntaxWarning: "is" with a literal. Did you mean "=="?
- if child_pid is 0:
---- a/src/binwalk/modules/extractor.py
-+++ b/src/binwalk/modules/extractor.py
-@@ -966,7 +966,7 @@ def shell_call(self, command):
-
- # Fork a child process
- child_pid = os.fork()
-- if child_pid is 0:
-+ if child_pid == 0:
- # Switch to the run-as user privileges, if one has been set
- if self.runas_uid is not None and self.runas_gid is not None:
- os.setgid(self.runas_uid)
-@@ -981,10 +981,10 @@ def shell_call(self, command):
- rval = subprocess.call(shlex.split(command), stdout=tmp, stderr=tmp)
-
- # A true child process should exit with the subprocess exit value
-- if child_pid is 0:
-+ if child_pid == 0:
- sys.exit(rval)
- # If no os.fork() happened, just return the subprocess exit value
-- elif child_pid is None:
-+ elif child_pid == None:
- return rval
- # Else, os.fork() happened and we're the parent. Wait and return the child's exit value.
- else:
-