summaryrefslogtreecommitdiff
path: root/app-misc/beanstalkd/beanstalkd-1.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/beanstalkd/beanstalkd-1.11.ebuild')
-rw-r--r--app-misc/beanstalkd/beanstalkd-1.11.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-misc/beanstalkd/beanstalkd-1.11.ebuild b/app-misc/beanstalkd/beanstalkd-1.11.ebuild
new file mode 100644
index 000000000000..427eb779418e
--- /dev/null
+++ b/app-misc/beanstalkd/beanstalkd-1.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils systemd toolchain-funcs user
+
+DESCRIPTION="A simple, fast work queue"
+HOMEPAGE="http://kr.github.io/beanstalkd/"
+SRC_URI="https://github.com/kr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~amd64-linux ~x64-macos ~x86-macos"
+
+RDEPEND=""
+DEPEND=""
+
+IUSE=""
+
+DOCS=( README News docs/protocol.txt )
+
+pkg_setup() {
+ enewuser beanstalk -1 -1 /var/lib/beanstalkd daemon
+}
+
+src_prepare() {
+ sed -i -e "/override/d" Makefile
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" LD="$(tc-getLD)"
+}
+
+src_install() {
+ dobin beanstalkd
+
+ DATADIR=/var/lib/${PN}
+ dodir ${DATADIR}
+ fowners beanstalk:daemon ${DATADIR}
+
+ doman doc/"${PN}".1
+
+ newconfd "${FILESDIR}/conf-1.9" beanstalkd
+ newinitd "${FILESDIR}/init-1.9" beanstalkd
+
+ systemd_dounit "${S}/adm/systemd/${PN}".{service,socket}
+}