summaryrefslogtreecommitdiff
path: root/app-metrics/bind_exporter/bind_exporter-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-metrics/bind_exporter/bind_exporter-0.3.0.ebuild')
-rw-r--r--app-metrics/bind_exporter/bind_exporter-0.3.0.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/app-metrics/bind_exporter/bind_exporter-0.3.0.ebuild b/app-metrics/bind_exporter/bind_exporter-0.3.0.ebuild
deleted file mode 100644
index 683d0803b1fa..000000000000
--- a/app-metrics/bind_exporter/bind_exporter-0.3.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module
-GIT_COMMIT=c34ff3d6b4817f42e74b2b05b3797cf99683b4a9
-
-DESCRIPTION="Prometheus exporter for BIND"
-HOMEPAGE="https://github.com/digitalocean/bind_exporter"
-SRC_URI="https://github.com/digitalocean/bind_exporter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-COMMON_DEPEND="acct-group/bind_exporter
- acct-user/bind_exporter"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-BDEPEND="dev-util/promu"
-
-src_prepare() {
- default
- sed -i -e "/-s$/d" -e "s/{{.Revision}}/${GIT_COMMIT}/" .promu.yml || die
-}
-
-src_compile() {
- mkdir -p bin || die
- promu build -v --prefix bin || die
-}
-
-src_test() {
- emake test-flags= test
-}
-
-src_install() {
- dobin bin/${PN}
- dodoc {README,CHANGELOG}.md
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- keepdir /var/log/${PN}
- fowners ${PN}:${PN} /var/log/${PN}
-}
-
-pkg_postinst() {
- elog "Make sure BIND was built with libxml2 support. You can check with the"
- elog "following command: named -V | grep libxml2."
- elog "Configure BIND to open a statistics channel. It's recommended to run"
- elog "the bind_exporter next to BIND, so it's only necessary to open a port"
- elog "locally."
- elog ""
- elog "statistics-channels {"
- elog "inet 127.0.0.1 port 8053 allow { 127.0.0.1; };"
- elog "};"
-}