summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-xproxy/lc-xproxy-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-xproxy/lc-xproxy-9999.ebuild')
-rw-r--r--app-leechcraft/lc-xproxy/lc-xproxy-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-leechcraft/lc-xproxy/lc-xproxy-9999.ebuild b/app-leechcraft/lc-xproxy/lc-xproxy-9999.ebuild
new file mode 100644
index 000000000000..90ec4fac3b5d
--- /dev/null
+++ b/app-leechcraft/lc-xproxy/lc-xproxy-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit leechcraft
+
+DESCRIPTION="Provides advanced proxy support features for LeechCraft"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ if ! has_version app-leechcraft/lc-qrosp || ! has_version dev-libs/qrosspython; then
+ einfo "XProxy supports scriptable host lists to match, for example, against all sites in RosKomNadzor registry."
+ einfo "Install app-lc/lc-qrosp and dev-libs/qrosspython to support these."
+ fi
+}