summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-secman/lc-secman-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-secman/lc-secman-9999.ebuild')
-rw-r--r--app-leechcraft/lc-secman/lc-secman-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-leechcraft/lc-secman/lc-secman-9999.ebuild b/app-leechcraft/lc-secman/lc-secman-9999.ebuild
new file mode 100644
index 000000000000..79aea9e550a6
--- /dev/null
+++ b/app-leechcraft/lc-secman/lc-secman-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit leechcraft
+
+DESCRIPTION="Security and personal data manager for LeechCraft"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug crypt exposecontents"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ crypt? ( dev-libs/openssl:0 )
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_SECMAN_SECURESTORAGE=$(usex crypt)
+ -DWITH_SECMAN_EXPOSE_CONTENTSDISPLAY=$(usex exposecontents)
+ )
+
+ cmake-utils_src_configure
+}