summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild')
-rw-r--r--app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild b/app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild
new file mode 100644
index 000000000000..4337e2d6adeb
--- /dev/null
+++ b/app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit leechcraft
+
+DESCRIPTION="Full-featured BitTorrent client plugin for LeechCraft"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug geoip"
+
+DEPEND="
+ ~app-leechcraft/lc-core-${PV}
+ net-libs/libtorrent-rasterbar
+ dev-qt/qtxml:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-task-show
+ geoip? ( dev-libs/geoip )
+"
+
+src_configure(){
+ local mycmakeargs=(
+ -DENABLE_BITTORRENT_GEOIP=$(usex geoip)
+ )
+ cmake-utils_src_configure
+}