summaryrefslogtreecommitdiff
path: root/app-laptop/tuxedo-keyboard
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/tuxedo-keyboard')
-rw-r--r--app-laptop/tuxedo-keyboard/Manifest3
-rw-r--r--app-laptop/tuxedo-keyboard/metadata.xml9
-rw-r--r--app-laptop/tuxedo-keyboard/tuxedo-keyboard-2.0.5.ebuild23
3 files changed, 35 insertions, 0 deletions
diff --git a/app-laptop/tuxedo-keyboard/Manifest b/app-laptop/tuxedo-keyboard/Manifest
new file mode 100644
index 000000000000..57e3baf9e707
--- /dev/null
+++ b/app-laptop/tuxedo-keyboard/Manifest
@@ -0,0 +1,3 @@
+DIST tuxedo-keyboard-2.0.5.tar.gz 31001 BLAKE2B 931d011e2ac521cef1670a8952886c1ac9b2476c6227c2b3cfce28d52622d3869f3c55773279eea3cbcc94d7c5b12d5d5653a8e2f9c142d0c044fa23fddd958c SHA512 3b7a9331d04e2918f3452f9561b05f39ea458960c2ade299a368899638987178cfd33fa066a0835f88b14c240d7937692d7994ccf978749ea7fdc428e587e06a
+EBUILD tuxedo-keyboard-2.0.5.ebuild 583 BLAKE2B 3633ae11af2f13a533feb53f2a3368ddc2b1a6a536903ecfe4312850d64b00f7f2ae1d81e12358515035e4bebbfe02640954602e7ae2898a7203f02d4f64c31d SHA512 eb48c301ebded725bb576736e611d8a187a0f9c9778cb272f6f1c881b108ea7b306e650f8822f78f9f5597b88344a55d80a6d9897b0cc305e54d558e5cf9914e
+MISC metadata.xml 257 BLAKE2B 509de9ecfaa2a50c6900b1ec69308a827823d04fcd54b77575b9b18b71b508bfeecb4be9e230324cadb1bc70674516d4e6744a0dd50ed0556fd71b7b2458f86e SHA512 5f02fa3554ba0e4203073be18f3962b6b6c4dec5b7bf36dcadd9de78827b31c766573268d6c9b092a4e7382557fe423fc31899cfe963ddbfae9ee6015c05c920
diff --git a/app-laptop/tuxedo-keyboard/metadata.xml b/app-laptop/tuxedo-keyboard/metadata.xml
new file mode 100644
index 000000000000..e42604230c16
--- /dev/null
+++ b/app-laptop/tuxedo-keyboard/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/app-laptop/tuxedo-keyboard/tuxedo-keyboard-2.0.5.ebuild b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-2.0.5.ebuild
new file mode 100644
index 000000000000..112e6376ad1a
--- /dev/null
+++ b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-2.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod toolchain-funcs
+
+DESCRIPTION="Kernel Module for Tuxedo Keyboard"
+HOMEPAGE="https://github.com/tuxedocomputers/tuxedo-keyboard"
+SRC_URI="https://github.com/tuxedocomputers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="all"
+MODULE_NAMES="tuxedo_keyboard(tuxedo:${S}:src)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KDIR=${KV_DIR} V=1 KBUILD_VERBOSE=1"
+}