summaryrefslogtreecommitdiff
path: root/app-laptop/tpacpi-bat/tpacpi-bat-1.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/tpacpi-bat/tpacpi-bat-1.1-r1.ebuild')
-rw-r--r--app-laptop/tpacpi-bat/tpacpi-bat-1.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-laptop/tpacpi-bat/tpacpi-bat-1.1-r1.ebuild b/app-laptop/tpacpi-bat/tpacpi-bat-1.1-r1.ebuild
new file mode 100644
index 000000000000..1560013b9e10
--- /dev/null
+++ b/app-laptop/tpacpi-bat/tpacpi-bat-1.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils systemd
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/teleshoes/tpacpi-bat.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/teleshoes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+DESCRIPTION="Control battery thresholds of recent ThinkPads, not supported by tp_smapi"
+HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-power/acpi_call
+ dev-lang/perl"
+
+src_install() {
+ dodoc README battery_asl
+ dobin tpacpi-bat
+ newinitd "${FILESDIR}"/${PN}.initd.1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd.0 ${PN}
+ systemd_newunit tpacpi.service ${PN}.service
+}