summaryrefslogtreecommitdiff
path: root/app-i18n
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/Manifest.gzbin18842 -> 18840 bytes
-rw-r--r--app-i18n/fcitx-libpinyin/Manifest2
-rw-r--r--app-i18n/fcitx-libpinyin/fcitx-libpinyin-0.5.4.ebuild74
-rw-r--r--app-i18n/libpinyin/Manifest2
-rw-r--r--app-i18n/libpinyin/libpinyin-2.6.2.ebuild2
5 files changed, 78 insertions, 2 deletions
diff --git a/app-i18n/Manifest.gz b/app-i18n/Manifest.gz
index e1a822a153fa..464c2412e3a9 100644
--- a/app-i18n/Manifest.gz
+++ b/app-i18n/Manifest.gz
Binary files differ
diff --git a/app-i18n/fcitx-libpinyin/Manifest b/app-i18n/fcitx-libpinyin/Manifest
index f5185c693224..33b349be59af 100644
--- a/app-i18n/fcitx-libpinyin/Manifest
+++ b/app-i18n/fcitx-libpinyin/Manifest
@@ -1,5 +1,7 @@
DIST fcitx-data-model.text.20161206.tar.gz 15099931 BLAKE2B 80e6a6fe5109011d6ea8683658d3fa89fc00e9dacfd140da3e993afc7db088c445da636797fbdac416e70119d37d47bdb0cb18d3865cebb397dbaa8a3055d703 SHA512 26450e347b7a211e5abd94acbb9befc8cee7d8fc20e5161ef11b8b9b1ad47cde4f1add5c41484d9af04e4dde2aa748090e297e799ee7f6d2f9fcec3873eee429
DIST fcitx-libpinyin-0.5.3_dict.tar.xz 15149856 BLAKE2B 35297477b3a4df9152162b8ad57d536333c5007510f387323d03e862901f17bb337504f20e6edc8d48e338916a6c4543900974027b60f7e87b0005f836677d29 SHA512 d132e0c007bd62286cfa89f6605a5315b6f5ae94a75bdd389fff1061e1547ad64c615fb0b75189d8cf35fa289a53e5d485911e06e368b2bf3af7b5a996fcd08a
+DIST fcitx-libpinyin-0.5.4_dict.tar.xz 15148952 BLAKE2B 1f6d3d4d334eafd24799b2bd6df9ad42318b819b8989600f0b89992640e45cd660e3b2c4e5c857c5ddccd7893182c41d6f7599a48a70129807922812e6ee9d7d SHA512 e91dbcb42bbaa74320ad593918c3c86cc6f6bc209f3f0fee2f8870c4fb86ecbf3c9f17618b8c8b29db67771fe54ffcffc79c62545299037dc623146e6073b2e1
EBUILD fcitx-libpinyin-0.5.3.ebuild 1601 BLAKE2B 180fe2f12f7dc9105b952d888c016fe4056d2b3a16e3fbf861a7ea6bed33e97b6ccd1fef6e06153df9b18543a5ee078a5588b4692ac7915c00d5dc70b0eeb42c SHA512 73a01b5853c521ae1a6b69bb9fc17d8df27b20444dd89ff1e6f2fb3fa036265eaa6ddb435bec5469f3d49cefab5d28296b5755481b26b6fa8a2e5dfa062e51fe
+EBUILD fcitx-libpinyin-0.5.4.ebuild 1612 BLAKE2B 474454604ef879ed79da79df53c5962c84ef0c51714db6651cee34fb025da010c7acb1ddc06c0c699e050e1a156508b60e41e0c5c4be6b145a651deedb765efc SHA512 5664f44497bce528f2a27d2add050553038fb5ec5383fd427c532408fd77c2e876b15622651845cf8fd23fa8620e33f1737ebc6fe1ae2ec437733f06e1eec6e9
EBUILD fcitx-libpinyin-4.9999.ebuild 1582 BLAKE2B e4664b16a52aa4ef11868cf67729c6dc53c77f4b8c16019ff700bae854cc7def01336c9d8c47e19568f9e08e6f2a8cc6c9d0b750d3669b49205e8d199ee8d0f8 SHA512 92b3610d1466a90bbe71b3132131df5592111fa8eb2051f59ba62b75a77374a593056e3617e58c6cc82c7c92d8a95f8c652cebcca8ac672b98646082b8204fd9
MISC metadata.xml 552 BLAKE2B c189c88f502c34a194efdaa673dabe5024bb1c484db0dd1a9a9f6bd00f95bb656c3c745cb6441c038126edc37076fd1e25ced12b6eb5905297712bcbce9c3e2d SHA512 eafec6117468965a4d670a018a4daa7b187814c57072825d5d65102f32b755061476a8747952a84433f7164aa6679cc60da6aa515596063f7de5b14757611a91
diff --git a/app-i18n/fcitx-libpinyin/fcitx-libpinyin-0.5.4.ebuild b/app-i18n/fcitx-libpinyin/fcitx-libpinyin-0.5.4.ebuild
new file mode 100644
index 000000000000..0a95023976d5
--- /dev/null
+++ b/app-i18n/fcitx-libpinyin/fcitx-libpinyin-0.5.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2012-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit cmake xdg-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-libpinyin"
+fi
+
+DESCRIPTION="Chinese LibPinyin input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-libpinyin"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI="https://download.fcitx-im.org/data/model.text.20161206.tar.gz -> fcitx-data-model.text.20161206.tar.gz"
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}_dict.tar.xz"
+fi
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="dictionary-manager"
+
+BDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/libpinyin-2.1.0
+ virtual/pkgconfig
+ dictionary-manager? (
+ >=dev-qt/qtcore-5.7:5
+ >=dev-qt/qtwidgets-5.7:5
+ )"
+DEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/libpinyin-2.1.0:=
+ dev-libs/glib:2
+ sys-apps/dbus
+ virtual/libintl
+ dictionary-manager? (
+ >=app-i18n/fcitx-qt5-1.1:4
+ >=dev-qt/qtcore-5.7:5
+ >=dev-qt/qtdbus-5.7:5
+ >=dev-qt/qtgui-5.7:5
+ >=dev-qt/qtnetwork-5.7:5
+ >=dev-qt/qtwebengine-5.7:5[widgets]
+ >=dev-qt/qtwidgets-5.7:5
+ )"
+RDEPEND="${DEPEND}"
+
+DOCS=(AUTHORS)
+
+src_prepare() {
+ if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ ln -s "${DISTDIR}/fcitx-data-model.text.20161206.tar.gz" data/model.text.20161206.tar.gz || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_QT=$(usex dictionary-manager)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/app-i18n/libpinyin/Manifest b/app-i18n/libpinyin/Manifest
index f6385e30713a..91f5df559028 100644
--- a/app-i18n/libpinyin/Manifest
+++ b/app-i18n/libpinyin/Manifest
@@ -1,5 +1,5 @@
DIST libpinyin-2.6.2.tar.gz 260101 BLAKE2B 7ba61c5bfe68991866112bbb63383bd7062164f92d63150b42c30f39d383f62a339a13eafa1596d1988d8e308c93ccc0f45cceeb557ce329788da507eed3e2ab SHA512 839907bed9bc796185fbe7d7b30ab84bc9bd45212797c75081475791aa62ad3465509ecc5fabe6ea27d02be9d2ca61764a472684b011b0c211bd5f4f26a0f9ca
DIST libpinyin-model19.text.tar.gz 20279012 BLAKE2B d8721d106235ef6fb99ad8dd4f4911bb23bf66f0259b01c39fd8ee829f0a63f326894802d62e51531a10f453dff1f4bb6e3e1648cf4aeac8213dccd10fc8ca4d SHA512 93c70423ba14faa3402bce775f82769dd4ee3a49083beddc540825f88facbd847328e9d01d99473adb7cf26de0f853e2b2e14fe849b1c49531134d1ca4ed2ef2
-EBUILD libpinyin-2.6.2.ebuild 1394 BLAKE2B c6c676e9de3a5465684644f2d8af146a961337b7663aa80685f5105715b0ed4c8fa7af742589e141116eee613cc8ea07323d48041ab20851ed9dbce157fdcc66 SHA512 0a10be6e75cda5df7dc878daabeca4d8448f720e693139f9ba85ab48fcb3d4e3326e42b453d0158f006af76e7acbd43cf2057d1cf1ea1388db9160b0491e962c
+EBUILD libpinyin-2.6.2.ebuild 1401 BLAKE2B f33b7c29cb746ce02099aec945dbc25dc1aea5c21d80019c09d91b10d2875d5904a24249bd4ad64f9fd1a2a2e3a9591f4908672c0993dde64d17d3460f710425 SHA512 7ac8c8b4eceece7f4e0b65cef9d130126cef0b9908081110184b638ad2eab3a6bc50737740e09950dcc556a4e98364e389c37ec6346ee8eb4cd6680cd29a29fa
EBUILD libpinyin-9999.ebuild 1371 BLAKE2B 387ed25199ff3c1d8e38ac48a270266e238b40caeb67a54517ba4106b031874efe9fd1775d1b0fc82eb8ba3bc4af773e41d0ffaed51d1082aa530ebb775d57aa SHA512 7d9a872d32124a3541643a04ecaff43d5a6215dce70aadf95f3e5d775dcb690be73ae2bda40baf17c75b2c9097ecc546206847234b4061ddb4f2595f5e4e60ef
MISC metadata.xml 521 BLAKE2B 829486b393163e4b4ac78807b37a57199f3fd07e94db186ba5a067b8a641412d8d83b95c56a4e0a56295b3c74f10277f1f4aa1a8be908596cb1252e13123341e SHA512 d93c02e8293534ca8a627e0504e5a0d69bd0c4b45b9395331183a35f4f4c81b267b80eb10d0c81a64628277e4770002e61c27e28c50fe84a6c390c473b73f41e
diff --git a/app-i18n/libpinyin/libpinyin-2.6.2.ebuild b/app-i18n/libpinyin/libpinyin-2.6.2.ebuild
index d58313fa9eca..e1119ca80bfc 100644
--- a/app-i18n/libpinyin/libpinyin-2.6.2.ebuild
+++ b/app-i18n/libpinyin/libpinyin-2.6.2.ebuild
@@ -24,7 +24,7 @@ SRC_URI+=" mirror://sourceforge/${PN}/models/model${LIBPINYIN_MODEL_VERSION}.tex
LICENSE="GPL-3+"
SLOT="0/13"
-KEYWORDS="amd64 ~arm64 ppc ppc64 x86"
+KEYWORDS="amd64 ~arm64 ppc ppc64 ~riscv x86"
IUSE=""
BDEPEND="virtual/pkgconfig"