summaryrefslogtreecommitdiff
path: root/app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20130108.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20130108.ebuild')
-rw-r--r--app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20130108.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20130108.ebuild b/app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20130108.ebuild
new file mode 100644
index 000000000000..108302b49c3b
--- /dev/null
+++ b/app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20130108.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit readme.gentoo scons-utils toolchain-funcs
+
+DESCRIPTION="The SunPinyin IMEngine Wrapper for XIM Framework"
+HOMEPAGE="https://sunpinyin.googlecode.com/"
+SRC_URI="https://dev.gentoo.org/~yngwin/distfiles/sunpinyin-${PV}.tar.xz"
+
+LICENSE="LGPL-2.1 CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="~app-i18n/sunpinyin-${PV}:=
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv "${WORKDIR}/sunpinyin-${PV}" "${S}" || die
+}
+
+src_configure() {
+ tc-export CXX
+ myesconsargs=( --prefix="${EPREFIX}/usr" )
+}
+
+src_compile() {
+ pushd "${S}"/wrapper/xim
+ escons
+ popd
+}
+
+src_install() {
+ pushd "${S}"/wrapper/xim
+ escons --install-sandbox="${D}" install
+ popd
+ readme.gentoo_create_doc
+}