summaryrefslogtreecommitdiff
path: root/app-i18n/unicode-cldr/unicode-cldr-33.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/unicode-cldr/unicode-cldr-33.0.ebuild')
-rw-r--r--app-i18n/unicode-cldr/unicode-cldr-33.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-i18n/unicode-cldr/unicode-cldr-33.0.ebuild b/app-i18n/unicode-cldr/unicode-cldr-33.0.ebuild
new file mode 100644
index 000000000000..2b0a7f62b66a
--- /dev/null
+++ b/app-i18n/unicode-cldr/unicode-cldr-33.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Unicode Common Locale Data Repository"
+HOMEPAGE="http://cldr.unicode.org/"
+if [[ "${PV}" =~ ^[[:digit:]]+\.0$ ]]; then
+ SRC_URI="https://unicode.org/Public/${PN#*-}/${PV%.0}/${PN#*-}-common-${PV}.zip -> ${PN}-common-${PV}.zip"
+else
+ SRC_URI="https://unicode.org/Public/${PN#*-}/${PV}/${PN#*-}-common-${PV}.zip -> ${PN}-common-${PV}.zip"
+fi
+
+LICENSE="unicode"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/unicode/cldr
+ doins -r common
+}