summaryrefslogtreecommitdiff
path: root/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild')
-rw-r--r--app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild b/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..28914bc279f6
--- /dev/null
+++ b/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Wijesekara keyboard for Sinhala input using scim"
+HOMEPAGE="http://sinhala.sourceforge.net/"
+SRC_URI="http://sinhala.sourceforge.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/scim-0.99.8[-gtk3]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc43.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # plugin module, no point in .la files
+ find "${D}" -name '*.la' -delete || die
+}