summaryrefslogtreecommitdiff
path: root/app-i18n/scim-m17n
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-m17n')
-rw-r--r--app-i18n/scim-m17n/Manifest3
-rw-r--r--app-i18n/scim-m17n/scim-m17n-0.2.3-r1.ebuild49
-rw-r--r--app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild10
3 files changed, 60 insertions, 2 deletions
diff --git a/app-i18n/scim-m17n/Manifest b/app-i18n/scim-m17n/Manifest
index 0948eff53453..8a29de6b2894 100644
--- a/app-i18n/scim-m17n/Manifest
+++ b/app-i18n/scim-m17n/Manifest
@@ -1,3 +1,4 @@
DIST scim-m17n-0.2.3.tar.gz 355801 BLAKE2B e6dbfd74ffdac4af4a1dea335a41eded6a499637e772dcb33295c4e5e25e2b04ba420b04ec7029bd6638ea22f74fc9a06f63a48114df7683486581686a733dd3 SHA512 c54be4c8c331d5621dcfa6c0c6f302231071dbbaf3ef7aee4117fe2c2616d58e184d3bae720dce27d5cb6567064add6979630090c72f9350391ca9c3e9c404f3
-EBUILD scim-m17n-0.2.3.ebuild 873 BLAKE2B 812029fbea815fdf23b303c59dbaa4d15a1729812e4587d249677b3c3accb609c7a2a980287089bf306e81f6b59c8cc5420efee9b3d4a9ec121e1b2fbf90489e SHA512 601d8b35ff133f1b8274caea985dba89d0eaadd352a3ad89d1172634a973f73a9992dffa0c6863ebefde9eb68d8070beae27a52654686a8335b8b168775a8590
+EBUILD scim-m17n-0.2.3-r1.ebuild 1039 BLAKE2B 22f55155d03d83ba28a56cc7dfdc789f842d2945adbaad50fc23793d1c1f7c45536805511febab21d3b104e5ec7fd12f2b4e3caa017e629fe9c4f94935c0a59c SHA512 1cb78aed308cba62533c46616e208e650fd0b35f8020d9075e01d986b266efef486e16c10e28995e0976f614fa5f4224194d69110a49b76c437da05d44ab2625
+EBUILD scim-m17n-0.2.3.ebuild 1005 BLAKE2B 707c3525b28a258204f5e72e8f13d84292c2e815e107bbc5140b0b34ca5482b6931ba879f89db2aeddabd919a81d0f68d8587d5fc2dd060c9f516fe1165628f8 SHA512 ee83f0cf26c72c74b8899ecd0df6340d5e09ea3475416dc58bdfec2fe2d97de5f02f25106c45237ffe5e020112a1d50119b55ee1f1c93c460ff5350194882bde
MISC metadata.xml 309 BLAKE2B dbae5a3009517b9481eba1b44e2db32c260bbb0f52aa2dc5ed112b782ddbed0da5094cda5ef43f87d5c7c2e2fd53683bafb15f968d46fdaa7e7172953090c951 SHA512 24868fa1884d67b6eef373a1571333f1ab4342fa982a782015383e27345f90eec98a32f4c8dbced47d3bd433edd2aaeb372360ebea8a36fabcd4e093dfd78e6b
diff --git a/app-i18n/scim-m17n/scim-m17n-0.2.3-r1.ebuild b/app-i18n/scim-m17n/scim-m17n-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..36ac1b4d7704
--- /dev/null
+++ b/app-i18n/scim-m17n/scim-m17n-0.2.3-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="An input module for Smart Common Input Method (SCIM) which uses m17n as backend"
+HOMEPAGE="http://www.scim-im.org/projects/imengines"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-i18n/scim-1.4
+ >=dev-libs/m17n-lib-1.2.0
+ dev-libs/libltdl
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ # update the 2009 era configure / libtool scripts, which fail with LTO
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=\"scim\""
+ elog
+}
diff --git a/app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild b/app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild
index 6fb3a51c366f..4f823e5eb9e6 100644
--- a/app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild
+++ b/app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit autotools
+
DESCRIPTION="An input module for Smart Common Input Method (SCIM) which uses m17n as backend"
HOMEPAGE="http://www.scim-im.org/projects/imengines"
SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
@@ -17,6 +19,12 @@ RDEPEND=">=app-i18n/scim-1.4
DEPEND="${RDEPEND}
virtual/pkgconfig"
+src_prepare() {
+ default
+ # update the 2009 era configure / libtool scripts, which fail with LTO
+ eautoreconf
+}
+
src_configure() {
econf --disable-static
}