summaryrefslogtreecommitdiff
path: root/app-i18n/libhangul/libhangul-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/libhangul/libhangul-0.1.0.ebuild')
-rw-r--r--app-i18n/libhangul/libhangul-0.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-i18n/libhangul/libhangul-0.1.0.ebuild b/app-i18n/libhangul/libhangul-0.1.0.ebuild
new file mode 100644
index 000000000000..ec22b8af6eca
--- /dev/null
+++ b/app-i18n/libhangul/libhangul-0.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="libhangul is a generalized and portable library for processing hangul"
+HOMEPAGE="https://code.google.com/p/libhangul/"
+SRC_URI="https://libhangul.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="nls static-libs test"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( dev-libs/check )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/lib*/libhangul.la
+}