summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-table-chinese/ibus-table-chinese-1.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-table-chinese/ibus-table-chinese-1.8.2.ebuild')
-rw-r--r--app-i18n/ibus-table-chinese/ibus-table-chinese-1.8.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/ibus-table-chinese/ibus-table-chinese-1.8.2.ebuild b/app-i18n/ibus-table-chinese/ibus-table-chinese-1.8.2.ebuild
new file mode 100644
index 000000000000..8d412b554c15
--- /dev/null
+++ b/app-i18n/ibus-table-chinese/ibus-table-chinese-1.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+CMAKE_IN_SOURCE_BUILD="1"
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+inherit cmake-utils
+
+DESCRIPTION="Chinese tables for IBus-Table"
+HOMEPAGE="https://github.com/definite/ibus-table-chinese"
+SRC_URI="https://github.com/definite/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-i18n/ibus-table"
+DEPEND="${RDEPEND}
+ dev-util/cmake-fedora"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_FEDORA_TMP_DIR="${T}"
+ -DDATA_DIR="${EPREFIX}"/usr/share
+ -DMANAGE_DEPENDENCY_PACKAGE_EXISTS_CMD=false
+ -DPRJ_DOC_DIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}