summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-qt
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-qt')
-rw-r--r--app-i18n/ibus-qt/Manifest4
-rw-r--r--app-i18n/ibus-qt/files/ibus-qt-doc.patch11
-rw-r--r--app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild53
-rw-r--r--app-i18n/ibus-qt/metadata.xml14
4 files changed, 82 insertions, 0 deletions
diff --git a/app-i18n/ibus-qt/Manifest b/app-i18n/ibus-qt/Manifest
new file mode 100644
index 000000000000..7362ac7d8c59
--- /dev/null
+++ b/app-i18n/ibus-qt/Manifest
@@ -0,0 +1,4 @@
+AUX ibus-qt-doc.patch 215 BLAKE2B 9895e1c72fac56052c6d7ef1bbf9702f5e89f4f9ef0afcb1682e41c51978aa1e8ff904039de0f1540177c44c071ef8e31791ce1312cba2b653e3df76797211cf SHA512 c6c46e8eb23bd9d6b21587f7f976a4bfc8f750e9135c8297224edf8ccfa3e97779144bcba661f4aa5a76226f59c1fc59da9e565a4b0b6d4285ac66f8ba0919c9
+DIST ibus-qt-1.3.3.tar.gz 141523 BLAKE2B 641ec53005ccb3b14646986bb0df4b091b88bcd4a181c82050d596f1840361d49451fcc1382d3fab1f54e463c9b0426b4f8bfd86b8f53224cb9c04dd298d5c87 SHA512 825a32fec51f10f466efd4255743a12ae98af63bacd07d5dc04e18fab6b830501b04491146c1f8bc92edd93dbf8eaeb68cf71062ffdbf25c2970d807b655c80a
+EBUILD ibus-qt-1.3.3.ebuild 989 BLAKE2B 9da6ca6e68818ad018b81ea5d831f0f22c11905c9c73764a4f0e29fd48aed35bdbc8acdd91f57c9a301f8b2f67dbf28e54c8b4077cb69da58d2843bd5db2a103 SHA512 af46f25f1e6ec3b0142bd88d53371541ba90404f6017fd64c9bd2e97f3f22f322c3e4f241675ca244ddd5f7282304b49977f9505a42653fecec5c6796089fd76
+MISC metadata.xml 427 BLAKE2B 9156e686bc1365dd3762c7550a07957a8b0320437c45a409e0127fb952bbc4c3cc0524437880cde421ff3e69fb232ddf16a65d2058da49c83f19fd1b74354372 SHA512 d8b71cd16b59609569170069a1cfd27bb09f5f6dce812e57550602fc5afc51eec23b9f646fe29145b0bdf3ae258868d4aead053444c290684696f344308a36ec
diff --git a/app-i18n/ibus-qt/files/ibus-qt-doc.patch b/app-i18n/ibus-qt/files/ibus-qt-doc.patch
new file mode 100644
index 000000000000..dbc1e9251369
--- /dev/null
+++ b/app-i18n/ibus-qt/files/ibus-qt-doc.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -77,7 +77,7 @@
+ pkg_check_modules(IBUS REQUIRED ibus-1.0>=1.3.7)
+
+ # check doxygen
+-find_package(Doxygen REQUIRED)
++find_package(Doxygen)
+
+ # =====
+ # Define variables
diff --git a/app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild b/app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild
new file mode 100644
index 000000000000..0ed171d32907
--- /dev/null
+++ b/app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Qt IBus library and Qt input method plugin"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="app-i18n/ibus
+ dev-libs/icu:=
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ sys-apps/dbus
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}"/${PN}-doc.patch )
+
+src_configure() {
+ append-cxxflags -std=c++14
+
+ local mycmakeargs=(
+ -DLIBDIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc; then
+ emake -C "${BUILD_DIR}" docs
+ fi
+}
+
+src_install() {
+ if use doc; then
+ HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ fi
+
+ cmake-utils_src_install
+}
diff --git a/app-i18n/ibus-qt/metadata.xml b/app-i18n/ibus-qt/metadata.xml
new file mode 100644
index 000000000000..4346ded0668a
--- /dev/null
+++ b/app-i18n/ibus-qt/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Qt client for IBus. It provides a Qt immodule.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ibus/ibus-qt</remote-id>
+ </upstream>
+</pkgmetadata>