summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild')
-rw-r--r--app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild b/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild
index cc7a98ca63d7..3a652f5a19c5 100644
--- a/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild
+++ b/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 2010-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit cmake-utils gnome2-utils
+inherit cmake xdg-utils
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
inherit git-r3
@@ -24,18 +24,19 @@ SLOT="4"
KEYWORDS=""
IUSE=""
-RDEPEND=">=app-i18n/fcitx-4.2.9:4
+BDEPEND="virtual/pkgconfig"
+DEPEND=">=app-i18n/fcitx-4.2.9:4
>=app-i18n/sunpinyin-2.0.4_alpha:=
virtual/libintl"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="${DEPEND}
+ app-i18n/sunpinyin-data"
DOCS=(AUTHORS)
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}