summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-lua/fcitx-lua-5.0.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-lua/fcitx-lua-5.0.13.ebuild')
-rw-r--r--app-i18n/fcitx-lua/fcitx-lua-5.0.13.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-i18n/fcitx-lua/fcitx-lua-5.0.13.ebuild b/app-i18n/fcitx-lua/fcitx-lua-5.0.13.ebuild
new file mode 100644
index 000000000000..7a101a7c365d
--- /dev/null
+++ b/app-i18n/fcitx-lua/fcitx-lua-5.0.13.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{3,4} )
+
+MY_PN="fcitx5-lua"
+
+inherit cmake lua-single xdg unpacker
+
+DESCRIPTION="Lua support for fcitx"
+HOMEPAGE="https://github.com/fcitx/fcitx5-lua"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.zst -> ${P}.tar.zst"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="+dlopen test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${LUA_DEPS}
+ app-i18n/fcitx:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ lua-single_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_DLOPEN=$(usex dlopen)
+ -DENABLE_TEST=$(usex test)
+ )
+ cmake_src_configure
+}